summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/modules.mk')
-rw-r--r--target/linux/at91/modules.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 7f98233eb5..6cfc3e4074 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -50,6 +50,24 @@ endef
$(eval $(call KernelPackage,at91-adc))
+define KernelPackage/at91-udc
+ SUBMENU:=$(USB_MENU)
+ TITLE:=USB Device Controller on atmel SoC
+ DEPENDS:=@TARGET_at91 +kmod-usb-gadget
+ KCONFIG:=CONFIG_USB_AT91
+ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/gadget/udc/at91_udc.ko),)
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/udc/at91_udc.ko
+else
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/at91_udc.ko
+endif
+ AUTOLOAD:=$(call AutoLoad,51,at91_udc)
+endef
+
+define KernelPackage/at91-adc/description
+ Kernel module to use the USB Device controller for Atmel AT91
+endef
+
+$(eval $(call KernelPackage,at91-udc))
I2C_AT91_MODULES:=\
CONFIG_I2C_AT91:drivers/i2c/busses/i2c-at91