summaryrefslogtreecommitdiffstats
path: root/target/linux/at91/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/Makefile')
-rw-r--r--target/linux/at91/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index f8ca6f6be3..7a9a1adcc3 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -14,14 +14,15 @@ FEATURES:=squashfs usb
#LINUX_VERSION:=2.6.21.5
LINUX_VERSION:=2.6.22.4
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
define Target/Description
Build fimware images for Figment Design Labs VersaLink board.
endef
-include $(INCLUDE_DIR)/kernel-build.mk
-
#include the profiles
-include profiles/*.mk
-KERNELNAME:="uImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))