summaryrefslogtreecommitdiffstats
path: root/target/linux/aruba-2.6/files/arch/mips/aruba/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/aruba-2.6/files/arch/mips/aruba/Makefile')
-rw-r--r--target/linux/aruba-2.6/files/arch/mips/aruba/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/target/linux/aruba-2.6/files/arch/mips/aruba/Makefile b/target/linux/aruba-2.6/files/arch/mips/aruba/Makefile
new file mode 100644
index 0000000000..94a55757ef
--- /dev/null
+++ b/target/linux/aruba-2.6/files/arch/mips/aruba/Makefile
@@ -0,0 +1,49 @@
+###############################################################################
+#
+# BRIEF MODULE DESCRIPTION
+# Makefile for IDT EB434 BSP
+#
+# Copyright 2004 IDT Inc. (rischelp@idt.com)
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 2 of the License, or (at your
+# option) any later version.
+#
+# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
+# NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+# INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+# NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
+# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
+# ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+###############################################################################
+# May 2004 rkt, neb
+#
+# Initial Release
+#
+#
+#
+###############################################################################
+
+
+# .S.s:
+# $(CPP) $(CFLAGS) $< -o $*.s
+# .S.o:
+# $(CC) $(CFLAGS) -c $< -o $*.o
+
+obj-y := prom.o setup.o irq.o time.o flash_lock.o
+obj-$(CONFIG_SERIAL_8250) += serial.o
+
+subdir-y += nvram
+obj-y += nvram/built-in.o
+