summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch')
-rw-r--r--target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch42
1 files changed, 0 insertions, 42 deletions
diff --git a/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch b/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch
deleted file mode 100644
index 70073109f4..0000000000
--- a/target/linux/ar71xx/patches-4.1/822-MIPS-ath79-Arduino-yun-support.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/arch/mips/ath79/Kconfig
-+++ b/arch/mips/ath79/Kconfig
-@@ -76,6 +76,19 @@ config ATH79_MACH_ANTMINER_S3
- select ATH79_DEV_USB
- select ATH79_DEV_WMAC
-
-+config ATH79_MACH_ARDUINO_YUN
-+ bool "Arduino Yun"
-+ select SOC_AR933X
-+ select ATH79_DEV_ETH
-+ select ATH79_DEV_GPIO_BUTTONS
-+ select ATH79_DEV_LEDS_GPIO
-+ select ATH79_DEV_M25P80
-+ select ATH79_DEV_USB
-+ select ATH79_DEV_WMAC
-+ help
-+ Say 'Y' here if you want your kernel to support the
-+ Arduino Yun.
-+
- config ATH79_MACH_AP113
- bool "Atheros AP113 board support"
- select SOC_AR724X
---- a/arch/mips/ath79/machtypes.h
-+++ b/arch/mips/ath79/machtypes.h
-@@ -23,6 +23,7 @@ enum ath79_mach_type {
- ATH79_MACH_ALL0315N, /* Allnet ALL0315N */
- ATH79_MACH_ANTMINER_S1, /* Antminer S1 */
- ATH79_MACH_ANTMINER_S3, /* Antminer S3 */
-+ ATH79_MACH_ARDUINO_YUN, /* Yun */
- ATH79_MACH_AP113, /* Atheros AP113 reference board */
- ATH79_MACH_AP121, /* Atheros AP121 reference board */
- ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
---- a/arch/mips/ath79/Makefile
-+++ b/arch/mips/ath79/Makefile
-@@ -44,6 +44,7 @@ obj-$(CONFIG_ATH79_MACH_ALL0258N) += mac
- obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
- obj-$(CONFIG_ATH79_MACH_ANTMINER_S1)+= mach-antminer-s1.o
- obj-$(CONFIG_ATH79_MACH_ANTMINER_S3)+= mach-antminer-s3.o
-+obj-$(CONFIG_ATH79_MACH_ARDUINO_YUN) += mach-arduino-yun.o
- obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
- obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
- obj-$(CONFIG_ATH79_MACH_AP132) += mach-ap132.o