summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch')
-rw-r--r--target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch24
1 files changed, 18 insertions, 6 deletions
diff --git a/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
index 02d996691e..02ebd1b4c9 100644
--- a/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-4.1/700-MIPS-ath79-openwrt-machines.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/ath79/machtypes.h
+++ b/arch/mips/ath79/machtypes.h
-@@ -16,24 +16,206 @@
+@@ -16,24 +16,207 @@
enum ath79_mach_type {
ATH79_MACH_GENERIC = 0,
@@ -82,6 +82,7 @@
+ ATH79_MACH_OM2P, /* OpenMesh OM2P */
+ ATH79_MACH_OM5P_AN, /* OpenMesh OM5P-AN */
+ ATH79_MACH_OM5P, /* OpenMesh OM5P */
++ ATH79_MACH_ONION_OMEGA, /* ONION OMEGA */
+ ATH79_MACH_PB42, /* Atheros PB42 */
+ ATH79_MACH_PB92, /* Atheros PB92 */
+ ATH79_MACH_QIHOO_C301, /* Qihoo 360 C301 */
@@ -300,7 +301,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +95,1097 @@ config ATH79_MACH_AP121
+@@ -11,62 +95,1107 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -1006,6 +1007,16 @@
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
++config ATH79_MACH_ONION_OMEGA
++ bool "ONION OMEGA support"
++ select SOC_AR933X
++ select ATH79_DEV_ETH
++ select ATH79_DEV_GPIO_BUTTONS
++ select ATH79_DEV_LEDS_GPIO
++ select ATH79_DEV_M25P80
++ select ATH79_DEV_USB
++ select ATH79_DEV_WMAC
++
+config ATH79_MACH_MR12
+ bool "Meraki MR12 board support"
+ select SOC_AR724X
@@ -1426,7 +1437,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1202,97 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1212,97 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -1524,7 +1535,7 @@
endmenu
config SOC_AR71XX
-@@ -134,7 +1344,10 @@ config ATH79_DEV_DSA
+@@ -134,7 +1354,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1536,7 +1547,7 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -164,6 +1377,11 @@ config ATH79_PCI_ATH9K_FIXUP
+@@ -164,6 +1387,11 @@ config ATH79_PCI_ATH9K_FIXUP
def_bool n
config ATH79_ROUTERBOOT
@@ -1550,7 +1561,7 @@
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
-@@ -38,9 +38,132 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
+@@ -38,9 +38,133 @@ obj-$(CONFIG_ATH79_ROUTERBOOT) += route
#
# Machines
#
@@ -1613,6 +1624,7 @@
+obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
+obj-$(CONFIG_ATH79_MACH_OM2P) += mach-om2p.o
+obj-$(CONFIG_ATH79_MACH_OM5P) += mach-om5p.o
++obj-$(CONFIG_ATH79_MACH_ONION_OMEGA) += mach-onion-omega.o
+obj-$(CONFIG_ATH79_MACH_PB42) += mach-pb42.o
obj-$(CONFIG_ATH79_MACH_PB44) += mach-pb44.o
+obj-$(CONFIG_ATH79_MACH_PB92) += mach-pb92.o