summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch')
-rw-r--r--target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch b/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
index d7107b0b68..17595368f9 100644
--- a/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
+++ b/target/linux/ar71xx/patches-3.10/413-mtd-ar934x-nand-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
-@@ -552,4 +552,8 @@ config MTD_NAND_RB750
+@@ -552,4 +552,12 @@ config MTD_NAND_RB750
tristate "NAND flash driver for the RouterBoard 750"
depends on MTD_NAND && ATH79_MACH_RB750
@@ -8,6 +8,10 @@
+ tristate "NAND flash driver for the Qualcomm Atheros AR934x/QCA955x SoCs"
+ depends on (SOC_AR934X || SOC_QCA955X)
+
++config MTD_NAND_AR934X_HW_ECC
++ bool "Hardware ECC support for the AR934X NAND Controller (EXPERIMENTAL)"
++ depends on MTD_NAND_AR934X
++
endif # MTD_NAND
--- a/drivers/mtd/nand/Makefile
+++ b/drivers/mtd/nand/Makefile