summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.27
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.27')
-rw-r--r--target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch21
-rw-r--r--target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch16
2 files changed, 7 insertions, 30 deletions
diff --git a/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch b/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch
index 1b1368bbc7..bba83bcab8 100644
--- a/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch
+++ b/target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch
@@ -14,27 +14,6 @@
# temporary until string.h is fixed
cflags-y += -ffreestanding
---- a/include/asm-mips/bootinfo.h
-+++ b/include/asm-mips/bootinfo.h
-@@ -57,6 +57,18 @@
- #define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
- #define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
-
-+/*
-+ * Valid machtype for Atheros AR71xx based boards
-+ */
-+#define MACH_AR71XX_GENERIC 0
-+#define MACH_AR71XX_WP543 1 /* Compex WP543 */
-+#define MACH_AR71XX_RB_411 2 /* MikroTik RouterBOARD 411/411A/411AH */
-+#define MACH_AR71XX_RB_433 3 /* MikroTik RouterBOARD 433/433AH */
-+#define MACH_AR71XX_RB_450 4 /* MikroTik RouterBOARD 450 */
-+#define MACH_AR71XX_RB_493 5 /* MikroTik RouterBOARD 493 */
-+#define MACH_AR71XX_AW_NR580 6 /* AzureWave AW-NR580 */
-+#define MACH_AR71XX_AP83 7 /* Atheros AP83 */
-+
- #define CL_SIZE COMMAND_LINE_SIZE
-
- extern char *system_type;
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -22,6 +22,23 @@ choice
diff --git a/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch b/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
index dced430213..e1fc84f656 100644
--- a/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
+++ b/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
@@ -1,6 +1,6 @@
--- /dev/null
+++ b/include/asm-mips/mips_machine.h
-@@ -0,0 +1,49 @@
+@@ -0,0 +1,47 @@
+/*
+ * Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *
@@ -16,8 +16,6 @@
+#include <linux/init.h>
+#include <linux/list.h>
+
-+#include <asm/bootinfo.h>
-+
+#define MIPS_MACHINE_NAME_LEN 64
+
+struct mips_machine {
@@ -28,7 +26,7 @@
+};
+
+void mips_machine_register(struct mips_machine *) __init;
-+void mips_machine_setup(void) __init;
++void mips_machine_setup(unsigned long machtype) __init;
+
+extern unsigned char mips_machine_name[MIPS_MACHINE_NAME_LEN];
+
@@ -90,14 +88,14 @@
+ list_add_tail(&mach->list, &mips_machines);
+}
+
-+void __init mips_machine_setup(void)
++void __init mips_machine_setup(unsigned long machtype)
+{
+ struct mips_machine *mach;
+
-+ mach = mips_machine_find(mips_machtype);
++ mach = mips_machine_find(machtype);
+ if (!mach) {
+ printk(KERN_ALERT "MIPS: no machine registered for "
-+ "machtype %lu\n", mips_machtype);
++ "machtype %lu\n", machtype);
+ return;
+ }
+
@@ -113,7 +111,7 @@
+
--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
-@@ -83,6 +83,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
+@@ -86,6 +86,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
@@ -123,7 +121,7 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -789,6 +789,9 @@ config MYLOADER
+@@ -858,6 +858,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K
bool