summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch')
-rw-r--r--target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch16
1 files changed, 7 insertions, 9 deletions
diff --git a/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch b/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
index dced430213..e1fc84f656 100644
--- a/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
+++ b/target/linux/ar71xx/patches-2.6.27/900-mips_multi_machine_support.patch
@@ -1,6 +1,6 @@
--- /dev/null
+++ b/include/asm-mips/mips_machine.h
-@@ -0,0 +1,49 @@
+@@ -0,0 +1,47 @@
+/*
+ * Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *
@@ -16,8 +16,6 @@
+#include <linux/init.h>
+#include <linux/list.h>
+
-+#include <asm/bootinfo.h>
-+
+#define MIPS_MACHINE_NAME_LEN 64
+
+struct mips_machine {
@@ -28,7 +26,7 @@
+};
+
+void mips_machine_register(struct mips_machine *) __init;
-+void mips_machine_setup(void) __init;
++void mips_machine_setup(unsigned long machtype) __init;
+
+extern unsigned char mips_machine_name[MIPS_MACHINE_NAME_LEN];
+
@@ -90,14 +88,14 @@
+ list_add_tail(&mach->list, &mips_machines);
+}
+
-+void __init mips_machine_setup(void)
++void __init mips_machine_setup(unsigned long machtype)
+{
+ struct mips_machine *mach;
+
-+ mach = mips_machine_find(mips_machtype);
++ mach = mips_machine_find(machtype);
+ if (!mach) {
+ printk(KERN_ALERT "MIPS: no machine registered for "
-+ "machtype %lu\n", mips_machtype);
++ "machtype %lu\n", machtype);
+ return;
+ }
+
@@ -113,7 +111,7 @@
+
--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
-@@ -83,6 +83,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
+@@ -86,6 +86,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
@@ -123,7 +121,7 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -789,6 +789,9 @@ config MYLOADER
+@@ -858,6 +858,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K
bool