summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/ubnt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/ubnt.mk')
-rw-r--r--target/linux/ar71xx/image/ubnt.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 98c9ca0066..5a4dc82c4f 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -48,7 +48,7 @@ define Device/ubnt-xm
UBNT_CHIP := ar7240
IMAGES := sysupgrade.bin factory.bin
IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage-split
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-xw
@@ -61,7 +61,7 @@ define Device/ubnt-xw
UBNT_CHIP := ar934x
IMAGES := sysupgrade.bin factory.bin
IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage-split
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-bz
@@ -74,7 +74,7 @@ define Device/ubnt-bz
UBNT_CHIP := ar934x
IMAGES := sysupgrade.bin factory.bin
IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage-split
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
define Device/ubnt-unifiac
@@ -83,7 +83,7 @@ define Device/ubnt-unifiac
IMAGE_SIZE := 7744k
MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
define Device/rw2458n
@@ -261,7 +261,7 @@ define Device/ubnt-uap-pro
DEVICE_PROFILE := UBNT UAPPRO
KERNEL := kernel-bin | patch-cmdline | lzma | uImage lzma | jffs2 kernel0
IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin = append-kernel $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin = $$(IMAGE/sysupgrade.bin) | mkubntimage2
endef