summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/legacy.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/legacy.mk')
-rw-r--r--target/linux/ar71xx/image/legacy.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 7e3f2934d4..cf3183e67a 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -1164,6 +1164,12 @@ $(eval $(call MultiProfile,Yun,YUN_16M YUN_8M))
$(eval $(call MultiProfile,Minimal,$(SINGLE_PROFILES)))
$(eval $(call MultiProfile,Madwifi,EAP7660D WP543))
+define LegacyDevice/OM2P
+ DEVICE_TITLE := OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-HSv2/OM2P-HSv3/OM2P-LC
+ DEVICE_PACKAGES := kmod-ath9k om-watchdog
+endef
+LEGACY_DEVICES += OM2P
+
endif # ifeq ($(SUBTARGET),generic)
ifeq ($(SUBTARGET),nand)
@@ -1209,6 +1215,15 @@ endif
$(call Image/Build/Profile/$(if $(CONFIG_IB),Default,$(IMAGE_PROFILE)),loader)
endef
+define Image/Prepare/Profile
+ $(call Image/Build/Profile/$(1),loader)
+endef
+
+define Image/Build/Profile
+ $(call Image/Build/Profile/$(1),buildkernel)
+ $(call Image/Build/Profile/$(1),$(2))
+endef
+
# $(1): filesystem type.
define Image/Build
$(call Image/Build/$(call rootfs_type,$(1)),$(1))