summaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile27
1 files changed, 3 insertions, 24 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 9209aa8d9f..2380a62cb4 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -21,6 +21,9 @@ include ./tp-link.mk
include ./ubnt.mk
include ./generic.mk
endif
+ifeq ($(SUBTARGET),nand)
+include ./nand.mk
+endif
include ./legacy.mk
define Build/netgear-squashfs
@@ -96,28 +99,4 @@ define Device/Default
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
endef
-ifeq ($(SUBTARGET),nand)
-
-define Build/MerakiNAND
- -$(STAGING_DIR_HOST)/bin/mkmerakifw \
- -B $(BOARDNAME) -s \
- -i $@ \
- -o $@.new
- @mv $@.new $@
-endef
-
-define Device/mr18
- BOARDNAME = MR18
- BLOCKSIZE := 64k
- CONSOLE = ttyS0,115200
- MTDPARTS = ar934x-nfc:512k(nandloader)ro,8M(kernel),8M(recovery),113664k(ubi),128k@130944k(odm-caldata)ro
- IMAGES := sysupgrade.tar
- KERNEL := kernel-bin | patch-cmdline | MerakiNAND
- KERNEL_INITRAMFS := kernel-bin | patch-cmdline | MerakiNAND
- IMAGE/sysupgrade.tar := sysupgrade-nand
-endef
-TARGET_DEVICES += mr18
-
-endif # ifeq ($(SUBTARGET),nand)
-
$(eval $(call BuildImage))