summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.30/100-board_support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7/patches-2.6.30/100-board_support.patch')
-rw-r--r--target/linux/ar7/patches-2.6.30/100-board_support.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar7/patches-2.6.30/100-board_support.patch b/target/linux/ar7/patches-2.6.30/100-board_support.patch
index c3fad1653a..079f9c0a8c 100644
--- a/target/linux/ar7/patches-2.6.30/100-board_support.patch
+++ b/target/linux/ar7/patches-2.6.30/100-board_support.patch
@@ -27,7 +27,7 @@
--- a/arch/mips/kernel/traps.c
+++ b/arch/mips/kernel/traps.c
-@@ -1203,9 +1203,22 @@ void *set_except_vector(int n, void *add
+@@ -1256,9 +1256,22 @@ void *set_except_vector(int n, void *add
exception_handlers[n] = handler;
if (n == 0 && cpu_has_divec) {
@@ -55,7 +55,7 @@
}
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -167,6 +167,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
+@@ -174,6 +174,13 @@ libs-$(CONFIG_SIBYTE_CFE) += arch/mips/s
#
#
@@ -71,7 +71,7 @@
core-$(CONFIG_MACH_JAZZ) += arch/mips/jazz/
--- a/arch/mips/include/asm/page.h
+++ b/arch/mips/include/asm/page.h
-@@ -182,8 +182,10 @@ typedef struct { unsigned long pgprot; }
+@@ -185,8 +185,10 @@ typedef struct { unsigned long pgprot; }
#define VM_DATA_DEFAULT_FLAGS (VM_READ | VM_WRITE | VM_EXEC | \
VM_MAYREAD | VM_MAYWRITE | VM_MAYEXEC)