summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch')
-rw-r--r--target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch b/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch
new file mode 100644
index 0000000000..79fcf45351
--- /dev/null
+++ b/target/linux/ar7/patches-2.6.23/200-ethernet_driver.patch
@@ -0,0 +1,32 @@
+Index: linux-2.6.23-rc6/drivers/net/Kconfig
+===================================================================
+--- linux-2.6.23-rc6.orig/drivers/net/Kconfig 2007-09-21 16:24:02.000000000 +0800
++++ linux-2.6.23-rc6/drivers/net/Kconfig 2007-09-21 16:24:13.000000000 +0800
+@@ -1965,6 +1965,15 @@
+ To compile this driver as a module, choose M here: the module
+ will be called sc92031. This is recommended.
+
++config CPMAC
++ tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"
++ depends on NET_ETHERNET && EXPERIMENTAL && AR7
++ select PHYLIB
++ select FIXED_PHY
++ select FIXED_MII_100_FDX
++ help
++ TI AR7 CPMAC Ethernet support
++
+ config NET_POCKET
+ bool "Pocket and portable adapters"
+ depends on PARPORT
+Index: linux-2.6.23-rc6/drivers/net/Makefile
+===================================================================
+--- linux-2.6.23-rc6.orig/drivers/net/Makefile 2007-09-21 16:24:02.000000000 +0800
++++ linux-2.6.23-rc6/drivers/net/Makefile 2007-09-21 16:24:13.000000000 +0800
+@@ -155,6 +155,7 @@
+ obj-$(CONFIG_8139TOO) += 8139too.o
+ obj-$(CONFIG_ZNET) += znet.o
+ obj-$(CONFIG_LAN_SAA9730) += saa9730.o
++obj-$(CONFIG_CPMAC) += cpmac.o
+ obj-$(CONFIG_DEPCA) += depca.o
+ obj-$(CONFIG_EWRK3) += ewrk3.o
+ obj-$(CONFIG_ATP) += atp.o