summaryrefslogtreecommitdiffstats
path: root/target/linux/ar7-2.6/patches/200-ethernet_driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7-2.6/patches/200-ethernet_driver.patch')
-rw-r--r--target/linux/ar7-2.6/patches/200-ethernet_driver.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/ar7-2.6/patches/200-ethernet_driver.patch b/target/linux/ar7-2.6/patches/200-ethernet_driver.patch
new file mode 100644
index 0000000000..ca603ad610
--- /dev/null
+++ b/target/linux/ar7-2.6/patches/200-ethernet_driver.patch
@@ -0,0 +1,30 @@
+diff -Nru linux-2.6.19.2/drivers/net/Kconfig linux-ar7/drivers/net/Kconfig
+--- linux-2.6.19.2/drivers/net/Kconfig 2006-12-12 02:32:53.000000000 +0700
++++ linux-ar7/drivers/net/Kconfig 2007-01-29 21:52:22.000000000 +0700
+@@ -1777,6 +1777,15 @@
+ workstations.
+ See <http://www.semiconductors.philips.com/pip/SAA9730_flyer_1>.
+
++config CPMAC
++ tristate "TI AR7 CPMAC Ethernet support (EXPERIMENTAL)"
++ depends on NET_ETHERNET && EXPERIMENTAL && AR7
++ select PHYLIB
++ select FIXED_PHY
++ select FIXED_MII_100_FDX
++ help
++ TI AR7 CPMAC Ethernet support
++
+ config NET_POCKET
+ bool "Pocket and portable adapters"
+ depends on NET_ETHERNET && PARPORT
+diff -Nru linux-2.6.19.2/drivers/net/Makefile linux-ar7/drivers/net/Makefile
+--- linux-2.6.19.2/drivers/net/Makefile 2006-12-12 02:32:53.000000000 +0700
++++ linux-ar7/drivers/net/Makefile 2007-01-29 21:52:22.000000000 +0700
+@@ -148,6 +148,7 @@
+ obj-$(CONFIG_8139TOO) += 8139too.o
+ obj-$(CONFIG_ZNET) += znet.o
+ obj-$(CONFIG_LAN_SAA9730) += saa9730.o
++obj-$(CONFIG_CPMAC) += cpmac.o
+ obj-$(CONFIG_DEPCA) += depca.o
+ obj-$(CONFIG_EWRK3) += ewrk3.o
+ obj-$(CONFIG_ATP) += atp.o