summaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/apm821xx/Makefile')
-rw-r--r--target/linux/apm821xx/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/apm821xx/Makefile b/target/linux/apm821xx/Makefile
new file mode 100644
index 0000000000..5c530d3ca6
--- /dev/null
+++ b/target/linux/apm821xx/Makefile
@@ -0,0 +1,28 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=apm821xx
+BOARDNAME:=AppliedMicro APM821xx
+CPU_TYPE:=464fp
+FEATURES:=fpu dt gpio
+MAINTAINER:=Chris Blake <chrisrblake93@gmail.com>, \
+ Christian Lamparter <chunkeey@gmail.com>
+
+KERNEL_PATCHVER:=4.4
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage
+
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
+
+define Target/Description
+ Build images for AppliedMicro APM821xx based boards.
+endef
+
+$(eval $(call BuildTarget))