summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches')
-rw-r--r--target/linux/adm5120/patches/001-adm5120.patch24
-rw-r--r--target/linux/adm5120/patches/002-adm5120_flash.patch16
-rw-r--r--target/linux/adm5120/patches/003-adm5120_switch.patch16
-rw-r--r--target/linux/adm5120/patches/005-adm5120_usb.patch24
-rw-r--r--target/linux/adm5120/patches/006-adm5120_leds.patch16
-rw-r--r--target/linux/adm5120/patches/007-adm5120_pci.patch14
-rw-r--r--target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch16
-rw-r--r--target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch16
-rw-r--r--target/linux/adm5120/patches/101-cfi_fixup_macronix_bootloc.patch18
-rw-r--r--target/linux/adm5120/patches/102-jedec_pmc_39lvxxx_chips.patch8
-rw-r--r--target/linux/adm5120/patches/103-mtd_trxsplit.patch16
-rw-r--r--target/linux/adm5120/patches/120-rb153_cf_driver.patch16
-rw-r--r--target/linux/adm5120/patches/140-cmdline_hack.patch6
-rw-r--r--target/linux/adm5120/patches/200-amba_pl010_hacks.patch66
-rw-r--r--target/linux/adm5120/patches/201-amba_bus_hacks.patch6
-rw-r--r--target/linux/adm5120/patches/202-pci_disable_common_quirks.patch20
-rw-r--r--target/linux/adm5120/patches/203-gpio_leds_brightness.patch8
-rw-r--r--target/linux/adm5120/patches/310-adm5120_wdt.patch16
18 files changed, 127 insertions, 195 deletions
diff --git a/target/linux/adm5120/patches/001-adm5120.patch b/target/linux/adm5120/patches/001-adm5120.patch
index 9280271800..26c0265049 100644
--- a/target/linux/adm5120/patches/001-adm5120.patch
+++ b/target/linux/adm5120/patches/001-adm5120.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/Kconfig
-+++ linux-2.6.24.7/arch/mips/Kconfig
-@@ -16,6 +16,20 @@ choice
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -16,6 +16,20 @@
prompt "System type"
default SGI_IP22
@@ -23,7 +21,7 @@ Index: linux-2.6.24.7/arch/mips/Kconfig
config MACH_ALCHEMY
bool "Alchemy processor based machines"
-@@ -689,6 +703,7 @@ config WR_PPMC
+@@ -689,6 +703,7 @@
endchoice
@@ -31,11 +29,9 @@ Index: linux-2.6.24.7/arch/mips/Kconfig
source "arch/mips/au1000/Kconfig"
source "arch/mips/jazz/Kconfig"
source "arch/mips/lasat/Kconfig"
-Index: linux-2.6.24.7/arch/mips/Makefile
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/Makefile
-+++ linux-2.6.24.7/arch/mips/Makefile
-@@ -166,6 +166,16 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -166,6 +166,16 @@
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#
@@ -52,10 +48,8 @@ Index: linux-2.6.24.7/arch/mips/Makefile
# Common Alchemy Au1x00 stuff
#
core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/
-Index: linux-2.6.24.7/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.24.7.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.24.7/include/asm-mips/bootinfo.h
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
@@ -198,6 +198,58 @@
#define MACH_GROUP_BRCM 23 /* Broadcom */
#define MACH_BCM47XX 1 /* Broadcom BCM47XX */
diff --git a/target/linux/adm5120/patches/002-adm5120_flash.patch b/target/linux/adm5120/patches/002-adm5120_flash.patch
index a81ccde50c..d2326fa959 100644
--- a/target/linux/adm5120/patches/002-adm5120_flash.patch
+++ b/target/linux/adm5120/patches/002-adm5120_flash.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/mtd/maps/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/maps/Kconfig
-+++ linux-2.6.24.7/drivers/mtd/maps/Kconfig
-@@ -597,5 +597,9 @@ config MTD_PLATRAM
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -597,5 +597,9 @@
This selection automatically selects the map_ram driver.
@@ -12,11 +10,9 @@ Index: linux-2.6.24.7/drivers/mtd/maps/Kconfig
+
endmenu
-Index: linux-2.6.24.7/drivers/mtd/maps/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/maps/Makefile
-+++ linux-2.6.24.7/drivers/mtd/maps/Makefile
-@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_DBOX2) += dbox2-flash.
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -45,6 +45,7 @@
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
obj-$(CONFIG_MTD_PCI) += pci.o
obj-$(CONFIG_MTD_ALCHEMY) += alchemy-flash.o
diff --git a/target/linux/adm5120/patches/003-adm5120_switch.patch b/target/linux/adm5120/patches/003-adm5120_switch.patch
index 7694eb0b31..1d2e428dde 100644
--- a/target/linux/adm5120/patches/003-adm5120_switch.patch
+++ b/target/linux/adm5120/patches/003-adm5120_switch.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/net/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/net/Kconfig
-+++ linux-2.6.24.7/drivers/net/Kconfig
-@@ -601,6 +601,10 @@ config MIPS_AU1X00_ENET
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -601,6 +601,10 @@
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@@ -13,11 +11,9 @@ Index: linux-2.6.24.7/drivers/net/Kconfig
config SGI_IOC3_ETH
bool "SGI IOC3 Ethernet"
depends on PCI && SGI_IP27
-Index: linux-2.6.24.7/drivers/net/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/net/Makefile
-+++ linux-2.6.24.7/drivers/net/Makefile
-@@ -183,6 +183,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -183,6 +183,7 @@
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o
diff --git a/target/linux/adm5120/patches/005-adm5120_usb.patch b/target/linux/adm5120/patches/005-adm5120_usb.patch
index ddb4a3df8f..ef9a4fd9d3 100644
--- a/target/linux/adm5120/patches/005-adm5120_usb.patch
+++ b/target/linux/adm5120/patches/005-adm5120_usb.patch
@@ -1,19 +1,15 @@
-Index: linux-2.6.24.7/drivers/usb/host/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/usb/host/Kconfig
-+++ linux-2.6.24.7/drivers/usb/host/Kconfig
-@@ -261,3 +261,6 @@ config USB_R8A66597_HCD
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -261,3 +261,6 @@
To compile this driver as a module, choose M here: the
module will be called r8a66597-hcd.
+config USB_ADM5120_HCD
+ tristate "ADM5120 HCD support (EXPERIMENTAL)"
+ depends on USB && MIPS_ADM5120 && EXPERIMENTAL
-Index: linux-2.6.24.7/drivers/usb/host/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/usb/host/Makefile
-+++ linux-2.6.24.7/drivers/usb/host/Makefile
-@@ -8,6 +8,7 @@ endif
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -8,6 +8,7 @@
obj-$(CONFIG_PCI) += pci-quirks.o
@@ -21,11 +17,9 @@ Index: linux-2.6.24.7/drivers/usb/host/Makefile
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
-Index: linux-2.6.24.7/drivers/usb/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/usb/Makefile
-+++ linux-2.6.24.7/drivers/usb/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -16,6 +16,7 @@
obj-$(CONFIG_USB_SL811_HCD) += host/
obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_USB_R8A66597_HCD) += host/
diff --git a/target/linux/adm5120/patches/006-adm5120_leds.patch b/target/linux/adm5120/patches/006-adm5120_leds.patch
index fc4943401e..6c8886da5c 100644
--- a/target/linux/adm5120/patches/006-adm5120_leds.patch
+++ b/target/linux/adm5120/patches/006-adm5120_leds.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/leds/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/leds/Kconfig
-+++ linux-2.6.24.7/drivers/leds/Kconfig
-@@ -18,6 +18,21 @@ config LEDS_CLASS
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -18,6 +18,21 @@
comment "LED drivers"
@@ -24,11 +22,9 @@ Index: linux-2.6.24.7/drivers/leds/Kconfig
config LEDS_CORGI
tristate "LED Support for the Sharp SL-C7x0 series"
depends on LEDS_CLASS && PXA_SHARP_C7xx
-Index: linux-2.6.24.7/drivers/leds/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/leds/Makefile
-+++ linux-2.6.24.7/drivers/leds/Makefile
-@@ -5,6 +5,7 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -5,6 +5,7 @@
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
# LED Platform Drivers
diff --git a/target/linux/adm5120/patches/007-adm5120_pci.patch b/target/linux/adm5120/patches/007-adm5120_pci.patch
index 2d6903cd3e..540b7d90ec 100644
--- a/target/linux/adm5120/patches/007-adm5120_pci.patch
+++ b/target/linux/adm5120/patches/007-adm5120_pci.patch
@@ -1,16 +1,12 @@
-Index: linux-2.6.24.7/arch/mips/pci/Makefile
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/pci/Makefile
-+++ linux-2.6.24.7/arch/mips/pci/Makefile
-@@ -48,3 +48,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -48,3 +48,4 @@
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o
-Index: linux-2.6.24.7/include/linux/pci_ids.h
-===================================================================
---- linux-2.6.24.7.orig/include/linux/pci_ids.h
-+++ linux-2.6.24.7/include/linux/pci_ids.h
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
@@ -1703,6 +1703,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
diff --git a/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
index cf10f7963c..bb04038753 100644
--- a/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/leds/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/leds/Kconfig
-+++ linux-2.6.24.7/drivers/leds/Kconfig
-@@ -178,4 +178,12 @@ config LEDS_TRIGGER_DEFAULT_ON
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -178,4 +178,12 @@
This allows LEDs to be initialised in the ON state.
If unsure, say Y.
@@ -15,11 +13,9 @@ Index: linux-2.6.24.7/drivers/leds/Kconfig
+ If unsure, say N.
+
endif # NEW_LEDS
-Index: linux-2.6.24.7/drivers/leds/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/leds/Makefile
-+++ linux-2.6.24.7/drivers/leds/Makefile
-@@ -28,3 +28,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -28,3 +28,4 @@
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
diff --git a/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch b/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
index 47166ed3cb..fe9c45b092 100644
--- a/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
+++ b/target/linux/adm5120/patches/100-mtd_myloder_partition_parser.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/mtd/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/Kconfig
-+++ linux-2.6.24.7/drivers/mtd/Kconfig
-@@ -160,6 +160,22 @@ config MTD_AFS_PARTS
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -160,6 +160,22 @@
for your particular device. It won't happen automatically. The
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
@@ -25,11 +23,9 @@ Index: linux-2.6.24.7/drivers/mtd/Kconfig
comment "User Modules And Translation Layers"
config MTD_CHAR
-Index: linux-2.6.24.7/drivers/mtd/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/Makefile
-+++ linux-2.6.24.7/drivers/mtd/Makefile
-@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -11,6 +11,7 @@
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
diff --git a/target/linux/adm5120/patches/101-cfi_fixup_macronix_bootloc.patch b/target/linux/adm5120/patches/101-cfi_fixup_macronix_bootloc.patch
index 859b5ca01a..9acb626bb5 100644
--- a/target/linux/adm5120/patches/101-cfi_fixup_macronix_bootloc.patch
+++ b/target/linux/adm5120/patches/101-cfi_fixup_macronix_bootloc.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/drivers/mtd/chips/cfi_cmdset_0002.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/chips/cfi_cmdset_0002.c
-+++ linux-2.6.24.7/drivers/mtd/chips/cfi_cmdset_0002.c
+--- a/drivers/mtd/chips/cfi_cmdset_0002.c
++++ b/drivers/mtd/chips/cfi_cmdset_0002.c
@@ -47,12 +47,19 @@
#define MANUFACTURER_AMD 0x0001
#define MANUFACTURER_ATMEL 0x001F
@@ -22,7 +20,7 @@ Index: linux-2.6.24.7/drivers/mtd/chips/cfi_cmdset_0002.c
static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
static int cfi_amdstd_write_buffers(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -217,6 +224,41 @@ static void fixup_use_atmel_lock(struct
+@@ -217,6 +224,41 @@
mtd->flags |= MTD_STUPID_LOCK;
}
@@ -64,7 +62,7 @@ Index: linux-2.6.24.7/drivers/mtd/chips/cfi_cmdset_0002.c
static struct cfi_fixup cfi_fixup_table[] = {
#ifdef AMD_BOOTLOC_BUG
{ CFI_MFR_AMD, CFI_ID_ANY, fixup_amd_bootblock, NULL },
-@@ -231,6 +273,9 @@ static struct cfi_fixup cfi_fixup_table[
+@@ -231,6 +273,9 @@
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_write_buffers, NULL, },
#endif
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
@@ -74,11 +72,9 @@ Index: linux-2.6.24.7/drivers/mtd/chips/cfi_cmdset_0002.c
{ 0, 0, NULL, NULL }
};
static struct cfi_fixup jedec_fixup_table[] = {
-Index: linux-2.6.24.7/drivers/mtd/chips/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/chips/Kconfig
-+++ linux-2.6.24.7/drivers/mtd/chips/Kconfig
-@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
+--- a/drivers/mtd/chips/Kconfig
++++ b/drivers/mtd/chips/Kconfig
+@@ -196,6 +196,14 @@
provides support for one of those command sets, used on chips
including the AMD Am29LV320.
diff --git a/target/linux/adm5120/patches/102-jedec_pmc_39lvxxx_chips.patch b/target/linux/adm5120/patches/102-jedec_pmc_39lvxxx_chips.patch
index 14c675cd91..0c512ea6a4 100644
--- a/target/linux/adm5120/patches/102-jedec_pmc_39lvxxx_chips.patch
+++ b/target/linux/adm5120/patches/102-jedec_pmc_39lvxxx_chips.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/drivers/mtd/chips/jedec_probe.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/chips/jedec_probe.c
-+++ linux-2.6.24.7/drivers/mtd/chips/jedec_probe.c
+--- a/drivers/mtd/chips/jedec_probe.c
++++ b/drivers/mtd/chips/jedec_probe.c
@@ -121,6 +121,10 @@
#define UPD29F064115 0x221C
@@ -13,7 +11,7 @@ Index: linux-2.6.24.7/drivers/mtd/chips/jedec_probe.c
#define PM49FL002 0x006D
#define PM49FL004 0x006E
#define PM49FL008 0x006A
-@@ -1264,6 +1268,58 @@ static const struct amd_flash_info jedec
+@@ -1264,6 +1268,58 @@
ERASEINFO(0x02000,2),
ERASEINFO(0x04000,1),
}
diff --git a/target/linux/adm5120/patches/103-mtd_trxsplit.patch b/target/linux/adm5120/patches/103-mtd_trxsplit.patch
index 73df926f74..267293aa56 100644
--- a/target/linux/adm5120/patches/103-mtd_trxsplit.patch
+++ b/target/linux/adm5120/patches/103-mtd_trxsplit.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/mtd/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/Kconfig
-+++ linux-2.6.24.7/drivers/mtd/Kconfig
-@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -57,6 +57,11 @@
depends on MTD_PARTITIONS
default y
@@ -14,11 +12,9 @@ Index: linux-2.6.24.7/drivers/mtd/Kconfig
config MTD_REDBOOT_PARTS
tristate "RedBoot partition table parsing"
depends on MTD_PARTITIONS
-Index: linux-2.6.24.7/drivers/mtd/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/mtd/Makefile
-+++ linux-2.6.24.7/drivers/mtd/Makefile
-@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
diff --git a/target/linux/adm5120/patches/120-rb153_cf_driver.patch b/target/linux/adm5120/patches/120-rb153_cf_driver.patch
index 0e9ddacdac..ad07b7a8a7 100644
--- a/target/linux/adm5120/patches/120-rb153_cf_driver.patch
+++ b/target/linux/adm5120/patches/120-rb153_cf_driver.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/ata/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/ata/Makefile
-+++ linux-2.6.24.7/drivers/ata/Makefile
-@@ -69,6 +69,7 @@ obj-$(CONFIG_PATA_BF54X) += pata_bf54x.o
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -69,6 +69,7 @@
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
@@ -10,11 +8,9 @@ Index: linux-2.6.24.7/drivers/ata/Makefile
# Should be last but two libata driver
obj-$(CONFIG_PATA_ACPI) += pata_acpi.o
# Should be last but one libata driver
-Index: linux-2.6.24.7/drivers/ata/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/ata/Kconfig
-+++ linux-2.6.24.7/drivers/ata/Kconfig
-@@ -660,4 +660,13 @@ config PATA_BF54X
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -660,4 +660,13 @@
If unsure, say N.
diff --git a/target/linux/adm5120/patches/140-cmdline_hack.patch b/target/linux/adm5120/patches/140-cmdline_hack.patch
index b366129c56..1ced3f62dd 100644
--- a/target/linux/adm5120/patches/140-cmdline_hack.patch
+++ b/target/linux/adm5120/patches/140-cmdline_hack.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/arch/mips/kernel/head.S
-===================================================================
---- linux-2.6.24.7.orig/arch/mips/kernel/head.S
-+++ linux-2.6.24.7/arch/mips/kernel/head.S
+--- a/arch/mips/kernel/head.S
++++ b/arch/mips/kernel/head.S
@@ -126,7 +126,12 @@
/*
* Reserved space for exception handlers.
diff --git a/target/linux/adm5120/patches/200-amba_pl010_hacks.patch b/target/linux/adm5120/patches/200-amba_pl010_hacks.patch
index 120d1ac316..97b06acec8 100644
--- a/target/linux/adm5120/patches/200-amba_pl010_hacks.patch
+++ b/target/linux/adm5120/patches/200-amba_pl010_hacks.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/serial/amba-pl010.c
-+++ linux-2.6.24.7/drivers/serial/amba-pl010.c
+--- a/drivers/serial/amba-pl010.c
++++ b/drivers/serial/amba-pl010.c
@@ -52,11 +52,10 @@
#include <asm/io.h>
@@ -16,7 +14,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
#define AMBA_ISR_PASS_LIMIT 256
-@@ -82,7 +81,7 @@ static void pl010_stop_tx(struct uart_po
+@@ -82,7 +81,7 @@
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -25,7 +23,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
cr &= ~UART010_CR_TIE;
writel(cr, uap->port.membase + UART010_CR);
}
-@@ -92,7 +91,7 @@ static void pl010_start_tx(struct uart_p
+@@ -92,7 +91,7 @@
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -34,7 +32,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
cr |= UART010_CR_TIE;
writel(cr, uap->port.membase + UART010_CR);
}
-@@ -102,7 +101,7 @@ static void pl010_stop_rx(struct uart_po
+@@ -102,7 +101,7 @@
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -43,7 +41,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
cr &= ~(UART010_CR_RIE | UART010_CR_RTIE);
writel(cr, uap->port.membase + UART010_CR);
}
-@@ -112,7 +111,7 @@ static void pl010_enable_ms(struct uart_
+@@ -112,7 +111,7 @@
struct uart_amba_port *uap = (struct uart_amba_port *)port;
unsigned int cr;
@@ -52,7 +50,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
cr |= UART010_CR_MSIE;
writel(cr, uap->port.membase + UART010_CR);
}
-@@ -122,9 +121,9 @@ static void pl010_rx_chars(struct uart_a
+@@ -122,9 +121,9 @@
struct tty_struct *tty = uap->port.info->tty;
unsigned int status, ch, flag, rsr, max_count = 256;
@@ -64,7 +62,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
flag = TTY_NORMAL;
uap->port.icount.rx++;
-@@ -133,7 +132,7 @@ static void pl010_rx_chars(struct uart_a
+@@ -133,7 +132,7 @@
* Note that the error handling code is
* out of the main execution path
*/
@@ -73,7 +71,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
if (unlikely(rsr & UART01x_RSR_ANY)) {
writel(0, uap->port.membase + UART01x_ECR);
-@@ -165,7 +164,7 @@ static void pl010_rx_chars(struct uart_a
+@@ -165,7 +164,7 @@
uart_insert_char(&uap->port, rsr, UART01x_RSR_OE, ch, flag);
ignore_char:
@@ -82,7 +80,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
}
spin_unlock(&uap->port.lock);
tty_flip_buffer_push(tty);
-@@ -210,7 +209,7 @@ static void pl010_modem_status(struct ua
+@@ -210,7 +209,7 @@
writel(0, uap->port.membase + UART010_ICR);
@@ -91,7 +89,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
delta = status ^ uap->old_status;
uap->old_status = status;
-@@ -238,7 +237,7 @@ static irqreturn_t pl010_int(int irq, vo
+@@ -238,7 +237,7 @@
spin_lock(&uap->port.lock);
@@ -100,7 +98,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
if (status) {
do {
if (status & (UART010_IIR_RTIS | UART010_IIR_RIS))
-@@ -251,7 +250,7 @@ static irqreturn_t pl010_int(int irq, vo
+@@ -251,7 +250,7 @@
if (pass_counter-- == 0)
break;
@@ -109,7 +107,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
} while (status & (UART010_IIR_RTIS | UART010_IIR_RIS |
UART010_IIR_TIS));
handled = 1;
-@@ -265,7 +264,7 @@ static irqreturn_t pl010_int(int irq, vo
+@@ -265,7 +264,7 @@
static unsigned int pl010_tx_empty(struct uart_port *port)
{
struct uart_amba_port *uap = (struct uart_amba_port *)port;
@@ -118,7 +116,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
return status & UART01x_FR_BUSY ? 0 : TIOCSER_TEMT;
}
-@@ -275,7 +274,7 @@ static unsigned int pl010_get_mctrl(stru
+@@ -275,7 +274,7 @@
unsigned int result = 0;
unsigned int status;
@@ -127,7 +125,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
if (status & UART01x_FR_DCD)
result |= TIOCM_CAR;
if (status & UART01x_FR_DSR)
-@@ -301,7 +300,7 @@ static void pl010_break_ctl(struct uart_
+@@ -301,7 +300,7 @@
unsigned int lcr_h;
spin_lock_irqsave(&uap->port.lock, flags);
@@ -136,7 +134,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
if (break_state == -1)
lcr_h |= UART01x_LCRH_BRK;
else
-@@ -334,7 +333,7 @@ static int pl010_startup(struct uart_por
+@@ -334,7 +333,7 @@
/*
* initialise the old status of the modem signals
*/
@@ -145,7 +143,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
/*
* Finally, enable interrupts
-@@ -365,7 +364,7 @@ static void pl010_shutdown(struct uart_p
+@@ -365,7 +364,7 @@
writel(0, uap->port.membase + UART010_CR);
/* disable break condition and fifos */
@@ -154,7 +152,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
~(UART01x_LCRH_BRK | UART01x_LCRH_FEN),
uap->port.membase + UART010_LCRH);
-@@ -387,7 +386,7 @@ pl010_set_termios(struct uart_port *port
+@@ -387,7 +386,7 @@
/*
* Ask the core to calculate the divisor for us.
*/
@@ -163,7 +161,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
quot = uart_get_divisor(port, baud);
switch (termios->c_cflag & CSIZE) {
-@@ -450,7 +449,7 @@ pl010_set_termios(struct uart_port *port
+@@ -450,7 +449,7 @@
uap->port.ignore_status_mask |= UART_DUMMY_RSR_RX;
/* first, disable everything */
@@ -172,7 +170,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
if (UART_ENABLE_MS(port, termios->c_cflag))
old_cr |= UART010_CR_MSIE;
-@@ -540,7 +539,7 @@ static struct uart_ops amba_pl010_pops =
+@@ -540,7 +539,7 @@
.verify_port = pl010_verify_port,
};
@@ -181,7 +179,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
#ifdef CONFIG_SERIAL_AMBA_PL010_CONSOLE
-@@ -550,7 +549,7 @@ static void pl010_console_putchar(struct
+@@ -550,7 +549,7 @@
unsigned int status;
do {
@@ -190,7 +188,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
barrier();
} while (!UART_TX_READY(status));
writel(ch, uap->port.membase + UART01x_DR);
-@@ -567,7 +566,7 @@ pl010_console_write(struct console *co,
+@@ -567,7 +566,7 @@
/*
* First save the CR then disable the interrupts
*/
@@ -199,7 +197,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
writel(UART01x_CR_UARTEN, uap->port.membase + UART010_CR);
uart_console_write(&uap->port, s, count, pl010_console_putchar);
-@@ -577,7 +576,7 @@ pl010_console_write(struct console *co,
+@@ -577,7 +576,7 @@
* and restore the TCR
*/
do {
@@ -208,7 +206,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
barrier();
} while (status & UART01x_FR_BUSY);
writel(old_cr, uap->port.membase + UART010_CR);
-@@ -589,9 +588,9 @@ static void __init
+@@ -589,9 +588,9 @@
pl010_console_get_options(struct uart_amba_port *uap, int *baud,
int *parity, int *bits)
{
@@ -220,7 +218,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
*parity = 'n';
if (lcr_h & UART01x_LCRH_PEN) {
-@@ -606,8 +605,8 @@ pl010_console_get_options(struct uart_am
+@@ -606,8 +605,8 @@
else
*bits = 8;
@@ -231,7 +229,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
*baud = uap->port.uartclk / (16 * (quot + 1));
}
}
-@@ -625,7 +624,7 @@ static int __init pl010_console_setup(st
+@@ -625,7 +624,7 @@
* if so, search for the first available port that does have
* console support.
*/
@@ -240,7 +238,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
co->index = 0;
uap = amba_ports[co->index];
if (!uap)
-@@ -643,7 +642,7 @@ static int __init pl010_console_setup(st
+@@ -643,7 +642,7 @@
static struct uart_driver amba_reg;
static struct console amba_console = {
@@ -249,7 +247,7 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
.write = pl010_console_write,
.device = uart_console_device,
.setup = pl010_console_setup,
-@@ -659,11 +658,11 @@ static struct console amba_console = {
+@@ -659,11 +658,11 @@
static struct uart_driver amba_reg = {
.owner = THIS_MODULE,
@@ -264,11 +262,9 @@ Index: linux-2.6.24.7/drivers/serial/amba-pl010.c
.cons = AMBA_CONSOLE,
};
-Index: linux-2.6.24.7/drivers/serial/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/serial/Kconfig
-+++ linux-2.6.24.7/drivers/serial/Kconfig
-@@ -287,10 +287,25 @@ config SERIAL_AMBA_PL010
+--- a/drivers/serial/Kconfig
++++ b/drivers/serial/Kconfig
+@@ -287,10 +287,25 @@
help
This selects the ARM(R) AMBA(R) PrimeCell PL010 UART. If you have
an Integrator/AP or Integrator/PP2 platform, or if you have a
diff --git a/target/linux/adm5120/patches/201-amba_bus_hacks.patch b/target/linux/adm5120/patches/201-amba_bus_hacks.patch
index 4fe89b991a..299f216523 100644
--- a/target/linux/adm5120/patches/201-amba_bus_hacks.patch
+++ b/target/linux/adm5120/patches/201-amba_bus_hacks.patch
@@ -1,7 +1,5 @@
-Index: linux-2.6.24.7/drivers/amba/bus.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/amba/bus.c
-+++ linux-2.6.24.7/drivers/amba/bus.c
+--- a/drivers/amba/bus.c
++++ b/drivers/amba/bus.c
@@ -17,6 +17,10 @@
#include <asm/io.h>
#include <asm/sizes.h>
diff --git a/target/linux/adm5120/patches/202-pci_disable_common_quirks.patch b/target/linux/adm5120/patches/202-pci_disable_common_quirks.patch
index 52fa931c84..13142add37 100644
--- a/target/linux/adm5120/patches/202-pci_disable_common_quirks.patch
+++ b/target/linux/adm5120/patches/202-pci_disable_common_quirks.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/pci/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/pci/Kconfig
-+++ linux-2.6.24.7/drivers/pci/Kconfig
-@@ -42,6 +42,12 @@ config PCI_DEBUG
+--- a/drivers/pci/Kconfig
++++ b/drivers/pci/Kconfig
+@@ -42,6 +42,12 @@
When in doubt, say N.
@@ -15,10 +13,8 @@ Index: linux-2.6.24.7/drivers/pci/Kconfig
config HT_IRQ
bool "Interrupts on hypertransport devices"
default y
-Index: linux-2.6.24.7/drivers/pci/quirks.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/pci/quirks.c
-+++ linux-2.6.24.7/drivers/pci/quirks.c
+--- a/drivers/pci/quirks.c
++++ b/drivers/pci/quirks.c
@@ -23,6 +23,7 @@
#include <linux/acpi.h>
#include "pci.h"
@@ -27,7 +23,7 @@ Index: linux-2.6.24.7/drivers/pci/quirks.c
/* The Mellanox Tavor device gives false positive parity errors
* Mark this device with a broken_parity_status, to allow
* PCI scanning code to "skip" this now blacklisted device.
-@@ -1480,6 +1481,7 @@ static void __devinit fixup_rev1_53c810(
+@@ -1480,6 +1481,7 @@
}
}
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -35,7 +31,7 @@ Index: linux-2.6.24.7/drivers/pci/quirks.c
static void pci_do_fixups(struct pci_dev *dev, struct pci_fixup *f, struct pci_fixup *end)
{
-@@ -1543,6 +1545,7 @@ void pci_fixup_device(enum pci_fixup_pas
+@@ -1543,6 +1545,7 @@
}
EXPORT_SYMBOL(pci_fixup_device);
@@ -43,7 +39,7 @@ Index: linux-2.6.24.7/drivers/pci/quirks.c
/* Enable 1k I/O space granularity on the Intel P64H2 */
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
{
-@@ -1756,3 +1759,4 @@ DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_AT
+@@ -1756,3 +1759,4 @@
quirk_msi_intx_disable_bug);
#endif /* CONFIG_PCI_MSI */
diff --git a/target/linux/adm5120/patches/203-gpio_leds_brightness.patch b/target/linux/adm5120/patches/203-gpio_leds_brightness.patch
index 1c53192bc3..3e9f5271c5 100644
--- a/target/linux/adm5120/patches/203-gpio_leds_brightness.patch
+++ b/target/linux/adm5120/patches/203-gpio_leds_brightness.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/leds/leds-gpio.c
-===================================================================
---- linux-2.6.24.7.orig/drivers/leds/leds-gpio.c
-+++ linux-2.6.24.7/drivers/leds/leds-gpio.c
-@@ -41,13 +41,17 @@ static void gpio_led_set(struct led_clas
+--- a/drivers/leds/leds-gpio.c
++++ b/drivers/leds/leds-gpio.c
+@@ -41,13 +41,17 @@
container_of(led_cdev, struct gpio_led_data, cdev);
int level;
diff --git a/target/linux/adm5120/patches/310-adm5120_wdt.patch b/target/linux/adm5120/patches/310-adm5120_wdt.patch
index 2729243466..1136ee8e65 100644
--- a/target/linux/adm5120/patches/310-adm5120_wdt.patch
+++ b/target/linux/adm5120/patches/310-adm5120_wdt.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.24.7/drivers/watchdog/Kconfig
-===================================================================
---- linux-2.6.24.7.orig/drivers/watchdog/Kconfig
-+++ linux-2.6.24.7/drivers/watchdog/Kconfig
-@@ -607,6 +607,18 @@ config SBC_EPX_C3_WATCHDOG
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -607,6 +607,18 @@
# MIPS Architecture
@@ -21,11 +19,9 @@ Index: linux-2.6.24.7/drivers/watchdog/Kconfig
config INDYDOG
tristate "Indy/I2 Hardware Watchdog"
depends on SGI_IP22
-Index: linux-2.6.24.7/drivers/watchdog/Makefile
-===================================================================
---- linux-2.6.24.7.orig/drivers/watchdog/Makefile
-+++ linux-2.6.24.7/drivers/watchdog/Makefile
-@@ -89,6 +89,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -89,6 +89,7 @@
# M68KNOMMU Architecture
# MIPS Architecture