summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch')
-rw-r--r--target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
index 60b78ebf73..fbd0626e69 100644
--- a/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches/009-adm5120_leds_switch_trigger.patch
@@ -1,10 +1,10 @@
-Index: linux-2.6.24/drivers/leds/Kconfig
+Index: linux-2.6.24.2/drivers/leds/Kconfig
===================================================================
---- linux-2.6.24.orig/drivers/leds/Kconfig
-+++ linux-2.6.24/drivers/leds/Kconfig
-@@ -171,4 +171,12 @@ config LEDS_TRIGGER_MORSE
- tristate "LED Morse Trigger"
- depends on LEDS_TRIGGERS
+--- linux-2.6.24.2.orig/drivers/leds/Kconfig
++++ linux-2.6.24.2/drivers/leds/Kconfig
+@@ -178,4 +178,12 @@ config LEDS_TRIGGER_DEFAULT_ON
+ This allows LEDs to be initialised in the ON state.
+ If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,12 +15,12 @@ Index: linux-2.6.24/drivers/leds/Kconfig
+ If unsure, say N.
+
endif # NEW_LEDS
-Index: linux-2.6.24/drivers/leds/Makefile
+Index: linux-2.6.24.2/drivers/leds/Makefile
===================================================================
---- linux-2.6.24.orig/drivers/leds/Makefile
-+++ linux-2.6.24/drivers/leds/Makefile
-@@ -27,3 +27,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+--- linux-2.6.24.2.orig/drivers/leds/Makefile
++++ linux-2.6.24.2/drivers/leds/Makefile
+@@ -28,3 +28,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o