summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch')
-rw-r--r--target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
new file mode 100644
index 0000000000..69f1035505
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.30/103-mtd_trxsplit.patch
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -63,6 +63,11 @@ config MTD_ROOTFS_SPLIT
+ depends on MTD_PARTITIONS
+ default y
+
++config MTD_TRXSPLIT
++ bool "Automatically find and split TRX partitions"
++ depends on MTD_PARTITIONS
++ default n
++
+ config MTD_REDBOOT_PARTS
+ tristate "RedBoot partition table parsing"
+ depends on MTD_PARTITIONS
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+ mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
+
+ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
++obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
+ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o