summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision')
-rw-r--r--target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/Makefile4
-rw-r--r--target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cas-771.c37
-rw-r--r--target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.c147
-rw-r--r--target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.h28
-rw-r--r--target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/nfs-101.c47
5 files changed, 0 insertions, 263 deletions
diff --git a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/Makefile b/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/Makefile
deleted file mode 100644
index a949fc9f61..0000000000
--- a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-obj-y += cellvision.o
-
-obj-$(CONFIG_ADM5120_MACH_CAS_771) += cas-771.o
-obj-$(CONFIG_ADM5120_MACH_NFS_101) += nfs-101.o
diff --git a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cas-771.c b/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cas-771.c
deleted file mode 100644
index 5033e02469..0000000000
--- a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cas-771.c
+++ /dev/null
@@ -1,37 +0,0 @@
-/*
- * Cellvision/SparkLAN CAS-771/771W support
- *
- * Copyright (C) 2007-2008 Gabor Juhos <juhosg@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- *
- */
-
-#include "cellvision.h"
-
-static struct adm5120_pci_irq cas771_pci_irqs[] __initdata = {
- PCIIRQ(2, 0, 1, ADM5120_IRQ_PCI0),
- PCIIRQ(3, 0, 1, ADM5120_IRQ_PCI1),
- PCIIRQ(3, 2, 3, ADM5120_IRQ_PCI2)
-};
-
-static struct gpio_led cas771_gpio_leds[] __initdata = {
- GPIO_LED_STD(ADM5120_GPIO_PIN0, "cam_flash", NULL),
- /* GPIO PIN3 is the reset */
- GPIO_LED_STD(ADM5120_GPIO_PIN6, "access", NULL),
- GPIO_LED_STD(ADM5120_GPIO_P0L1, "status", NULL),
- GPIO_LED_STD(ADM5120_GPIO_P0L2, "diag", NULL),
-};
-
-static void __init cas771_setup(void)
-{
- cas7xx_setup();
- adm5120_add_device_gpio_leds(ARRAY_SIZE(cas771_gpio_leds),
- cas771_gpio_leds);
- adm5120_pci_set_irq_map(ARRAY_SIZE(cas771_pci_irqs), cas771_pci_irqs);
-}
-
-MIPS_MACHINE(MACH_ADM5120_CAS771, "CAS-771", "Cellvision CAS-771/771W",
- cas771_setup);
diff --git a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.c b/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.c
deleted file mode 100644
index a7cedf03bc..0000000000
--- a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.c
+++ /dev/null
@@ -1,147 +0,0 @@
-/*
- * Cellvision/SparkLAN boards
- *
- * Copyright (C) 2007-2008 Gabor Juhos <juhosg@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- *
- */
-
-#include "cellvision.h"
-
-#include <prom/admboot.h>
-
-#define CELLVISION_GPIO_FLASH_A20 ADM5120_GPIO_PIN5
-#define CELLVISION_GPIO_DEV_MASK (1 << CELLVISION_GPIO_FLASH_A20)
-
-#define CELLVISION_CONFIG_OFFSET 0x8000
-#define CELLVISION_CONFIG_SIZE 0x1000
-
-static struct mtd_partition cas6xx_partitions[] = {
- {
- .name = "admboot",
- .offset = 0,
- .size = 32*1024,
- .mask_flags = MTD_WRITEABLE,
- } , {
- .name = "config",
- .offset = MTDPART_OFS_APPEND,
- .size = 32*1024,
- } , {
- .name = "nvfs1",
- .offset = MTDPART_OFS_APPEND,
- .size = 64*1024,
- } , {
- .name = "nvfs2",
- .offset = MTDPART_OFS_APPEND,
- .size = 64*1024,
- } , {
- .name = "firmware",
- .offset = MTDPART_OFS_APPEND,
- .size = MTDPART_SIZ_FULL,
- }
-};
-
-static struct mtd_partition cas7xx_partitions[] = {
- {
- .name = "admboot",
- .offset = 0,
- .size = 32*1024,
- .mask_flags = MTD_WRITEABLE,
- } , {
- .name = "config",
- .offset = MTDPART_OFS_APPEND,
- .size = 32*1024,
- } , {
- .name = "nvfs",
- .offset = MTDPART_OFS_APPEND,
- .size = 128*1024,
- } , {
- .name = "firmware",
- .offset = MTDPART_OFS_APPEND,
- .size = MTDPART_SIZ_FULL,
- }
-};
-
-static void switch_bank_gpio5(unsigned bank)
-{
- switch (bank) {
- case 0:
- gpio_set_value(CELLVISION_GPIO_FLASH_A20, 0);
- break;
- case 1:
- gpio_set_value(CELLVISION_GPIO_FLASH_A20, 1);
- break;
- }
-}
-
-static void __init cellvision_flash_setup(void)
-{
- /* setup flash A20 line */
- gpio_request(CELLVISION_GPIO_FLASH_A20, NULL);
- gpio_direction_output(CELLVISION_GPIO_FLASH_A20, 0);
-
- adm5120_flash0_data.switch_bank = switch_bank_gpio5;
- adm5120_add_device_flash(0);
-}
-
-void __init cellvision_mac_setup(void)
-{
- u8 mac_base[6];
- int err;
-
- err = admboot_get_mac_base(CELLVISION_CONFIG_OFFSET,
- CELLVISION_CONFIG_SIZE, mac_base);
-
- if ((err) || !is_valid_ether_addr(mac_base))
- random_ether_addr(mac_base);
-
- adm5120_setup_eth_macs(mac_base);
-}
-
-void __init cas6xx_flash_setup(void)
-{
- adm5120_flash0_data.nr_parts = ARRAY_SIZE(cas6xx_partitions);
- adm5120_flash0_data.parts = cas6xx_partitions;
-
- cellvision_flash_setup();
-}
-
-void __init cas7xx_flash_setup(void)
-{
- adm5120_flash0_data.nr_parts = ARRAY_SIZE(cas7xx_partitions);
- adm5120_flash0_data.parts = cas7xx_partitions;
-
- cellvision_flash_setup();
-}
-
-void __init cas6xx_setup(void)
-{
- cas6xx_flash_setup();
- adm5120_add_device_uart(0);
- adm5120_add_device_uart(1);
- adm5120_add_device_switch(1, NULL);
-}
-
-MIPS_MACHINE(MACH_ADM5120_CAS630, "CAS-630", "Cellvision CAS-630/630W",
- cas6xx_setup);
-MIPS_MACHINE(MACH_ADM5120_CAS670, "CAS-670", "Cellvision CAS-670/670W",
- cas6xx_setup);
-
-void __init cas7xx_setup(void)
-{
- cas7xx_flash_setup();
- cellvision_mac_setup();
- adm5120_add_device_uart(0);
- adm5120_add_device_uart(1);
- adm5120_add_device_switch(1, NULL);
-}
-
-MIPS_MACHINE(MACH_ADM5120_CAS700, "CAS-700", "Cellvision CAS-700/700W",
- cas7xx_setup);
-MIPS_MACHINE(MACH_ADM5120_CAS790, "CAS-790", "Cellvision CAS-790",
- cas7xx_setup);
-MIPS_MACHINE(MACH_ADM5120_CAS861, "CAS-861", "Cellvision CAS-861/861W",
- cas7xx_setup);
diff --git a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.h b/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.h
deleted file mode 100644
index 2b55ebf761..0000000000
--- a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/cellvision.h
+++ /dev/null
@@ -1,28 +0,0 @@
-/*
- * Cellvision/SparkLAN boards
- *
- * Copyright (C) 2007-2008 Gabor Juhos <juhosg@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- *
- */
-
-#include <linux/kernel.h>
-#include <linux/init.h>
-#include <linux/gpio.h>
-#include <linux/irq.h>
-#include <linux/etherdevice.h>
-
-#include <asm/mips_machine.h>
-
-#include <asm/mach-adm5120/adm5120_info.h>
-#include <asm/mach-adm5120/adm5120_platform.h>
-
-extern void cellvision_mac_setup(void) __init;
-
-extern void cas6xx_flash_setup(void) __init;
-extern void cas7xx_flash_setup(void) __init;
-extern void cas6xx_setup(void) __init;
-extern void cas7xx_setup(void) __init;
diff --git a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/nfs-101.c b/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/nfs-101.c
deleted file mode 100644
index 7d214c0909..0000000000
--- a/target/linux/adm5120/files-3.14/arch/mips/adm5120/cellvision/nfs-101.c
+++ /dev/null
@@ -1,47 +0,0 @@
-/*
- * Cellvision/SparkLAN NFS-101U/WU support
- *
- * Copyright (C) 2007-2009 Gabor Juhos <juhosg@openwrt.org>
- *
- * This program is free software; you can redistribute it and/or modify it
- * under the terms of the GNU General Public License version 2 as published
- * by the Free Software Foundation.
- *
- */
-
-#include "cellvision.h"
-
-static struct adm5120_pci_irq nfs101_pci_irqs[] __initdata = {
- /* miniPCI slot */
- PCIIRQ(2, 0, 1, ADM5120_IRQ_PCI0),
-
- /* ALi USB controller */
- PCIIRQ(3, 0, 2, ADM5120_IRQ_PCI2),
- PCIIRQ(3, 3, 1, ADM5120_IRQ_PCI1),
-
- /* NEC USB controller */
- PCIIRQ(3, 0, 1, ADM5120_IRQ_PCI1),
- PCIIRQ(3, 1, 2, ADM5120_IRQ_PCI2),
- PCIIRQ(3, 2, 3, ADM5120_IRQ_PCI2),
-};
-
-static u8 nfs101_vlans[6] __initdata = {
- /* FIXME: not tested */
- 0x5f, 0x00, 0x00, 0x00, 0x00, 0x00
-};
-
-static void __init nfs101_setup(void)
-{
- cas6xx_flash_setup();
- cellvision_mac_setup();
-
- adm5120_add_device_uart(0);
- adm5120_add_device_uart(1);
- adm5120_add_device_switch(1, nfs101_vlans);
-
- adm5120_pci_set_irq_map(ARRAY_SIZE(nfs101_pci_irqs),
- nfs101_pci_irqs);
-}
-
-MIPS_MACHINE(MACH_ADM5120_NFS101U, "NFS-101U", "Cellvision NFS-101U/101WU",
- nfs101_setup);