summaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/Makefile')
-rw-r--r--target/linux/adm5120/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index f8436c04ed..34c3b804a7 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -1,27 +1,20 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
include $(TOPDIR)/rules.mk
-ARCH:=mipsel
BOARD:=adm5120
-BOARDNAME:=ADM5120 (Little Endian)
-FEATURES:=squashfs jffs2 tgz broken
-
LINUX_VERSION:=2.6.22.4
+FEATURES:=squashfs jffs2 tgz broken
-define Target/Description
- Build firmware images for Infineon/ADMtek ADM5120 based boards
- (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
-endef
+include $(INCLUDE_DIR)/target.mk
-include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += admswconfig
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call Target,router_be))
+$(eval $(call Target,router_le))
+$(eval $(call BuildTarget))