summaryrefslogtreecommitdiffstats
path: root/target/imagebuilder
diff options
context:
space:
mode:
Diffstat (limited to 'target/imagebuilder')
-rw-r--r--target/imagebuilder/Makefile14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 218def7e1d..7f48ed885f 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -37,20 +37,10 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
ifeq ($(CONFIG_IB_STANDALONE),)
echo '## Remote package repositories' >> $(PKG_BUILD_DIR)/repositories.conf
- ifeq ($(CONFIG_PER_FEED_REPO),)
- echo "src/gz %n %U" >> $(PKG_BUILD_DIR)/repositories.conf
- else
- for d in base $(FEEDS_ENABLED); do \
- echo "src/gz %n_$$d %U/$$d" >> $(PKG_BUILD_DIR)/repositories.conf; \
- done
- ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
- for d in $(FEEDS_DISABLED); do \
- echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$$d %U/$$d" >> $(PKG_BUILD_DIR)/repositories.conf; \
- done
- endif
- endif
+ $(call FeedSourcesAppend,$(PKG_BUILD_DIR)/repositories.conf)
endif
+ echo '' >> $(PKG_BUILD_DIR)/repositories.conf
echo '## This is the local package repository, do not remove!' >> $(PKG_BUILD_DIR)/repositories.conf
echo 'src imagebuilder file:packages' >> $(PKG_BUILD_DIR)/repositories.conf