summaryrefslogtreecommitdiffstats
path: root/scripts/config/lxdialog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/config/lxdialog/Makefile')
-rw-r--r--scripts/config/lxdialog/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/scripts/config/lxdialog/Makefile b/scripts/config/lxdialog/Makefile
new file mode 100644
index 0000000000..a82b2bac99
--- /dev/null
+++ b/scripts/config/lxdialog/Makefile
@@ -0,0 +1,20 @@
+# Makefile to build lxdialog package
+#
+
+all: lxdialog
+
+# Use reursively expanded variables so we do not call gcc unless
+# we really need to do so. (Do not call gcc as part of make mrproper)
+CFLAGS := $(shell sh check-lxdialog.sh -ccflags)
+LIBS := $(shell sh check-lxdialog.sh -ldflags gcc)
+
+always := $(hostprogs-y) dochecklxdialog
+
+%.o: %.c
+ $(CC) -c $(CFLAGS) -o $@ $<
+
+lxdialog: checklist.o menubox.o textbox.o yesno.o inputbox.o util.o lxdialog.o msgbox.o
+ $(CC) -o $@ $^ $(LIBS)
+
+clean:
+ rm -f *.o lxdialog