summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/sound.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index d09cf21aba..52a44d6a8a 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -259,12 +259,10 @@ define KernelPackage/pcspkr
DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support
KCONFIG:= \
- CONFIG_INPUT_PCSPKR \
CONFIG_SND_PCSP
FILES:= \
- $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
$(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
- AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
+ AUTOLOAD:=$(call AutoLoad,50,snd-pcsp)
$(call AddDepends/sound)
endef