summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/functions.sh7
2 files changed, 4 insertions, 5 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 3ba30c3abc..f0b2e37d5b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=146
+PKG_RELEASE:=147
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/lib/functions.sh b/package/base-files/files/lib/functions.sh
index 19cfbae172..6cb6df92fd 100755
--- a/package/base-files/files/lib/functions.sh
+++ b/package/base-files/files/lib/functions.sh
@@ -248,17 +248,16 @@ mtd_get_mac_ascii()
local part
local mac_dirty
- . /lib/functions.sh
-
part=$(find_mtd_part "$mtdname")
if [ -z "$part" ]; then
echo "mtd_get_mac_ascii: partition $mtdname not found!" >&2
return
fi
- mac_dirty=$(strings "$part" | sed -n 's/'"$key"'=//p')
+ mac_dirty=$(strings "$part" | sed -n 's/^'"$key"'=//p')
+
# "canonicalize" mac
- printf "%02x:%02x:%02x:%02x:%02x:%02x" 0x${mac_dirty//:/ 0x}
+ [ -n "$mac_dirty" ] && echo ${mac_dirty} | tr [A-F] [a-f]
}
mtd_get_mac_binary() {