summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index a36993e483..52c28c9110 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1626,3 +1626,20 @@ define KernelPackage/usb3/description
endef
$(eval $(call KernelPackage,usb3))
+
+
+define KernelPackage/usb-net2280
+ TITLE:=Support for NetChip 228x PCI USB peripheral controller
+ KCONFIG:= CONFIG_USB_NET2280
+ DEPENDS:=@PCI_SUPPORT +kmod-usb-gadget
+ FILES:=$(LINUX_DIR)/drivers/usb/gadget/udc/net2280.ko
+ AUTOLOAD:=$(call AutoLoad,46,net2280)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-net2280/description
+ Kernel support for NetChip 228x / PLX USB338x PCI USB peripheral controller.
+endef
+
+$(eval $(call KernelPackage,usb-net2280))
+