summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/patches/020-wext-fix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/mac80211/patches/020-wext-fix.patch b/package/mac80211/patches/020-wext-fix.patch
new file mode 100644
index 0000000000..157b4e4ef1
--- /dev/null
+++ b/package/mac80211/patches/020-wext-fix.patch
@@ -0,0 +1,11 @@
+--- a/scripts/gen-compat-autoconf.sh
++++ b/scripts/gen-compat-autoconf.sh
+@@ -192,7 +192,7 @@ if [ -f $KLIB_BUILD/Makefile ]; then
+ define_config_multiple_deps CONFIG_MAC80211_QOS y $ALL_DEPS
+ rm -f $MULT_DEP_FILE
+ # Kernels >= 2.6.32 can disable WEXT :D
+- if [ $SUBLEVEL -le 32 ]; then
++ if [ $SUBLEVEL -le 35 ]; then
+ define_config_dep CONFIG_CFG80211_WEXT 1 CONFIG_WIRELESS_EXT
+ fi
+ fi