summaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/config
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/busybox/config')
-rw-r--r--package/utils/busybox/config/Config.in22
-rw-r--r--package/utils/busybox/config/archival/Config.in29
-rw-r--r--package/utils/busybox/config/coreutils/Config.in39
-rw-r--r--package/utils/busybox/config/debianutils/Config.in5
-rw-r--r--package/utils/busybox/config/e2fsprogs/Config.in34
-rw-r--r--package/utils/busybox/config/init/Config.in49
-rw-r--r--package/utils/busybox/config/libbb/Config.in48
-rw-r--r--package/utils/busybox/config/loginutils/Config.in112
-rw-r--r--package/utils/busybox/config/miscutils/Config.in22
-rw-r--r--package/utils/busybox/config/modutils/Config.in3
-rw-r--r--package/utils/busybox/config/networking/Config.in15
-rw-r--r--package/utils/busybox/config/printutils/Config.in2
-rw-r--r--package/utils/busybox/config/runit/Config.in65
-rw-r--r--package/utils/busybox/config/sysklogd/Config.in121
-rw-r--r--package/utils/busybox/config/util-linux/Config.in45
-rw-r--r--package/utils/busybox/config/util-linux/volume_id/Config.in8
16 files changed, 350 insertions, 269 deletions
diff --git a/package/utils/busybox/config/Config.in b/package/utils/busybox/config/Config.in
index 113eb62067..3bf67c5cf3 100644
--- a/package/utils/busybox/config/Config.in
+++ b/package/utils/busybox/config/Config.in
@@ -115,9 +115,21 @@ config BUSYBOX_CONFIG_FEATURE_COMPRESS_USAGE
and have very little memory, this might not be a win. Otherwise,
you probably want this.
+config BUSYBOX_CONFIG_BUSYBOX
+ bool "Include busybox applet"
+ default BUSYBOX_DEFAULT_BUSYBOX
+ help
+ The busybox applet provides general help regarding busybox and
+ allows the included applets to be listed. It's also required
+ if applet links are to be installed at runtime.
+
+ If you can live without these features disabling this will save
+ some space.
+
config BUSYBOX_CONFIG_FEATURE_INSTALLER
bool "Support --install [-s] to install applet links at runtime"
default BUSYBOX_DEFAULT_FEATURE_INSTALLER
+ depends on BUSYBOX_CONFIG_BUSYBOX
help
Enable 'busybox --install [-s]' support. This will allow you to use
busybox at runtime to create hard links or symlinks for all the
@@ -687,6 +699,16 @@ config BUSYBOX_CONFIG_DEBUG_PESSIMIZE
in a much bigger executable that more closely matches the source
code.
+config BUSYBOX_CONFIG_DEBUG_SANITIZE
+ bool "Enable runtime sanitizers (ASAN/LSAN/USAN/etc...)"
+ default BUSYBOX_DEFAULT_DEBUG_SANITIZE
+ help
+ Say Y here if you want to enable runtime sanitizers. These help
+ catch bad memory accesses (e.g. buffer overflows), but will make
+ the executable larger and slow down runtime a bit.
+
+ If you aren't developing/testing busybox, say N here.
+
config BUSYBOX_CONFIG_UNIT_TEST
bool "Build unit tests"
default BUSYBOX_DEFAULT_UNIT_TEST
diff --git a/package/utils/busybox/config/archival/Config.in b/package/utils/busybox/config/archival/Config.in
index 1ca610cad6..ff4c2cf6bd 100644
--- a/package/utils/busybox/config/archival/Config.in
+++ b/package/utils/busybox/config/archival/Config.in
@@ -32,7 +32,7 @@ config BUSYBOX_CONFIG_FEATURE_SEAMLESS_GZ
config BUSYBOX_CONFIG_FEATURE_SEAMLESS_Z
bool "tar, rpm, modprobe etc understand .Z data"
- default BUSYBOX_DEFAULT_FEATURE_SEAMLESS_Z
+ default BUSYBOX_DEFAULT_FEATURE_SEAMLESS_Z # it is ancient
help
Make tar, rpm, modprobe etc understand .Z data.
@@ -41,23 +41,13 @@ config BUSYBOX_CONFIG_AR
default BUSYBOX_DEFAULT_AR # needs to be improved to be able to replace binutils ar
help
ar is an archival utility program used to create, modify, and
- extract contents from archives. An archive is a single file holding
- a collection of other files in a structure that makes it possible to
- retrieve the original individual files (called archive members).
- The original files' contents, mode (permissions), timestamp, owner,
- and group are preserved in the archive, and can be restored on
- extraction.
-
- The stored filename is limited to 15 characters. (for more information
- see long filename support).
- ar has 60 bytes of overheads for every stored file.
-
- This implementation of ar can extract archives, it cannot create or
- modify them.
+ extract contents from archives. In practice, it is used exclusively
+ for object module archives used by compilers.
+
On an x86 system, the ar applet adds about 1K.
Unless you have a specific application which requires ar, you should
- probably say N here.
+ probably say N here: most compilers come with their own ar utility.
config BUSYBOX_CONFIG_FEATURE_AR_LONG_FILENAMES
bool "Support for long filenames (not needed for debs)"
@@ -77,7 +67,7 @@ config BUSYBOX_CONFIG_FEATURE_AR_CREATE
This enables archive creation (-c and -r) with busybox ar.
config BUSYBOX_CONFIG_UNCOMPRESS
bool "uncompress"
- default BUSYBOX_DEFAULT_UNCOMPRESS
+ default BUSYBOX_DEFAULT_UNCOMPRESS # ancient
help
uncompress is used to decompress archives created by compress.
Not much used anymore, replaced by gzip/gunzip.
@@ -88,6 +78,13 @@ config BUSYBOX_CONFIG_GUNZIP
gunzip is used to decompress archives created by gzip.
You can use the `-t' option to test the integrity of
an archive, without decompressing it.
+
+config BUSYBOX_CONFIG_FEATURE_GUNZIP_LONG_OPTIONS
+ bool "Enable long options"
+ default BUSYBOX_DEFAULT_FEATURE_GUNZIP_LONG_OPTIONS
+ depends on BUSYBOX_CONFIG_GUNZIP && BUSYBOX_CONFIG_LONG_OPTS
+ help
+ Enable use of long options.
config BUSYBOX_CONFIG_BUNZIP2
bool "bunzip2"
default BUSYBOX_DEFAULT_BUNZIP2
diff --git a/package/utils/busybox/config/coreutils/Config.in b/package/utils/busybox/config/coreutils/Config.in
index 2f9473857b..ec5611bdfd 100644
--- a/package/utils/busybox/config/coreutils/Config.in
+++ b/package/utils/busybox/config/coreutils/Config.in
@@ -123,6 +123,29 @@ config BUSYBOX_CONFIG_SHUF
default BUSYBOX_DEFAULT_SHUF
help
Generate random permutations
+config BUSYBOX_CONFIG_STAT
+ bool "stat"
+ default BUSYBOX_DEFAULT_STAT
+ help
+ display file or filesystem status.
+
+config BUSYBOX_CONFIG_FEATURE_STAT_FORMAT
+ bool "Enable custom formats (-c)"
+ default BUSYBOX_DEFAULT_FEATURE_STAT_FORMAT
+ depends on BUSYBOX_CONFIG_STAT
+ help
+ Without this, stat will not support the '-c format' option where
+ users can pass a custom format string for output. This adds about
+ 7k to a nonstatic build on amd64.
+
+config BUSYBOX_CONFIG_FEATURE_STAT_FILESYSTEM
+ bool "Enable display of filesystem status (-f)"
+ default BUSYBOX_DEFAULT_FEATURE_STAT_FILESYSTEM
+ depends on BUSYBOX_CONFIG_STAT
+ select BUSYBOX_CONFIG_PLATFORM_LINUX # statfs()
+ help
+ Without this, stat will not support the '-f' option to display
+ information about filesystem status.
config BUSYBOX_CONFIG_SYNC
bool "sync"
default BUSYBOX_DEFAULT_SYNC
@@ -760,22 +783,6 @@ config BUSYBOX_CONFIG_FEATURE_SPLIT_FANCY
Supports additional suffixes 'b' for 512 bytes,
'g' for 1GiB for the -b option.
-config BUSYBOX_CONFIG_STAT
- bool "stat"
- default BUSYBOX_DEFAULT_STAT
- select BUSYBOX_CONFIG_PLATFORM_LINUX # statfs()
- help
- display file or filesystem status.
-
-config BUSYBOX_CONFIG_FEATURE_STAT_FORMAT
- bool "Enable custom formats (-c)"
- default BUSYBOX_DEFAULT_FEATURE_STAT_FORMAT
- depends on BUSYBOX_CONFIG_STAT
- help
- Without this, stat will not support the '-c format' option where
- users can pass a custom format string for output. This adds about
- 7k to a nonstatic build on amd64.
-
config BUSYBOX_CONFIG_STTY
bool "stty"
default BUSYBOX_DEFAULT_STTY
diff --git a/package/utils/busybox/config/debianutils/Config.in b/package/utils/busybox/config/debianutils/Config.in
index 533ad475c1..d39c60f43e 100644
--- a/package/utils/busybox/config/debianutils/Config.in
+++ b/package/utils/busybox/config/debianutils/Config.in
@@ -6,19 +6,16 @@
menu "Debian Utilities"
-
config BUSYBOX_CONFIG_MKTEMP
bool "mktemp"
default BUSYBOX_DEFAULT_MKTEMP
help
mktemp is used to create unique temporary files
-
config BUSYBOX_CONFIG_PIPE_PROGRESS
bool "pipe_progress"
default BUSYBOX_DEFAULT_PIPE_PROGRESS
help
Display a dot to indicate pipe activity.
-
config BUSYBOX_CONFIG_RUN_PARTS
bool "run-parts"
default BUSYBOX_DEFAULT_RUN_PARTS
@@ -49,7 +46,6 @@ config BUSYBOX_CONFIG_FEATURE_RUN_PARTS_FANCY
Support additional options:
-l --list print the names of the all matching files (not
limited to executables), but don't actually run them.
-
config BUSYBOX_CONFIG_START_STOP_DAEMON
bool "start-stop-daemon"
default BUSYBOX_DEFAULT_START_STOP_DAEMON
@@ -74,7 +70,6 @@ config BUSYBOX_CONFIG_FEATURE_START_STOP_DAEMON_LONG_OPTIONS
depends on BUSYBOX_CONFIG_START_STOP_DAEMON && BUSYBOX_CONFIG_LONG_OPTS
help
Support long options for the start-stop-daemon applet.
-
config BUSYBOX_CONFIG_WHICH
bool "which"
default BUSYBOX_DEFAULT_WHICH
diff --git a/package/utils/busybox/config/e2fsprogs/Config.in b/package/utils/busybox/config/e2fsprogs/Config.in
index f826240181..df255481c3 100644
--- a/package/utils/busybox/config/e2fsprogs/Config.in
+++ b/package/utils/busybox/config/e2fsprogs/Config.in
@@ -6,22 +6,11 @@
menu "Linux Ext2 FS Progs"
-
config BUSYBOX_CONFIG_CHATTR
bool "chattr"
default BUSYBOX_DEFAULT_CHATTR
help
chattr changes the file attributes on a second extended file system.
-
-### config E2FSCK
-### bool "e2fsck"
-### default y
-### help
-### e2fsck is used to check Linux second extended file systems (ext2fs).
-### e2fsck also supports ext2 filesystems countaining a journal (ext3).
-### The normal compat symlinks 'fsck.ext2' and 'fsck.ext3' are also
-### provided.
-
config BUSYBOX_CONFIG_FSCK
bool "fsck"
default BUSYBOX_DEFAULT_FSCK
@@ -29,13 +18,27 @@ config BUSYBOX_CONFIG_FSCK
fsck is used to check and optionally repair one or more filesystems.
In actuality, fsck is simply a front-end for the various file system
checkers (fsck.fstype) available under Linux.
-
config BUSYBOX_CONFIG_LSATTR
bool "lsattr"
default BUSYBOX_DEFAULT_LSATTR
select BUSYBOX_CONFIG_PLATFORM_LINUX
help
lsattr lists the file attributes on a second extended file system.
+config BUSYBOX_CONFIG_TUNE2FS
+ bool "tune2fs"
+ default BUSYBOX_DEFAULT_TUNE2FS # off: it is too limited compared to upstream version
+ help
+ tune2fs allows the system administrator to adjust various tunable
+ filesystem parameters on Linux ext2/ext3 filesystems.
+
+### config E2FSCK
+### bool "e2fsck"
+### default y
+### help
+### e2fsck is used to check Linux second extended file systems (ext2fs).
+### e2fsck also supports ext2 filesystems countaining a journal (ext3).
+### The normal compat symlinks 'fsck.ext2' and 'fsck.ext3' are also
+### provided.
### config MKE2FS
### bool "mke2fs"
@@ -44,13 +47,6 @@ config BUSYBOX_CONFIG_LSATTR
### mke2fs is used to create an ext2/ext3 filesystem. The normal compat
### symlinks 'mkfs.ext2' and 'mkfs.ext3' are also provided.
-config BUSYBOX_CONFIG_TUNE2FS
- bool "tune2fs"
- default BUSYBOX_DEFAULT_TUNE2FS # off: it is too limited compared to upstream version
- help
- tune2fs allows the system administrator to adjust various tunable
- filesystem parameters on Linux ext2/ext3 filesystems.
-
### config E2LABEL
### bool "e2label"
### default y
diff --git a/package/utils/busybox/config/init/Config.in b/package/utils/busybox/config/init/Config.in
index 634207f7f9..021656d3f9 100644
--- a/package/utils/busybox/config/init/Config.in
+++ b/package/utils/busybox/config/init/Config.in
@@ -76,10 +76,21 @@ config BUSYBOX_CONFIG_INIT
help
init is the first program run when the system boots.
+config BUSYBOX_CONFIG_LINUXRC
+ bool "Support running init from within an initrd (not initramfs)"
+ default BUSYBOX_DEFAULT_LINUXRC
+ select BUSYBOX_CONFIG_FEATURE_SYSLOG
+ help
+ Legacy support for running init under the old-style initrd. Allows
+ the name linuxrc to act as init, and it doesn't assume init is PID 1.
+
+ This does not apply to initramfs, which runs /init as PID 1 and
+ requires no special support.
+
config BUSYBOX_CONFIG_FEATURE_USE_INITTAB
bool "Support reading an inittab file"
default BUSYBOX_DEFAULT_FEATURE_USE_INITTAB
- depends on BUSYBOX_CONFIG_INIT
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
help
Allow init to read an inittab file when the system boot.
@@ -106,7 +117,7 @@ config BUSYBOX_CONFIG_FEATURE_KILL_DELAY
config BUSYBOX_CONFIG_FEATURE_INIT_SCTTY
bool "Run commands with leading dash with controlling tty"
default BUSYBOX_DEFAULT_FEATURE_INIT_SCTTY
- depends on BUSYBOX_CONFIG_INIT
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
help
If this option is enabled, init will try to give a controlling
tty to any command which has leading hyphen (often it's "-/bin/sh").
@@ -121,40 +132,29 @@ config BUSYBOX_CONFIG_FEATURE_INIT_SCTTY
config BUSYBOX_CONFIG_FEATURE_INIT_SYSLOG
bool "Enable init to write to syslog"
default BUSYBOX_DEFAULT_FEATURE_INIT_SYSLOG
- depends on BUSYBOX_CONFIG_INIT
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
config BUSYBOX_CONFIG_FEATURE_EXTRA_QUIET
bool "Be _extra_ quiet on boot"
default BUSYBOX_DEFAULT_FEATURE_EXTRA_QUIET
- depends on BUSYBOX_CONFIG_INIT
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
help
Prevent init from logging some messages to the console during boot.
config BUSYBOX_CONFIG_FEATURE_INIT_COREDUMPS
bool "Support dumping core for child processes (debugging only)"
default BUSYBOX_DEFAULT_FEATURE_INIT_COREDUMPS
- depends on BUSYBOX_CONFIG_INIT
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
help
If this option is enabled and the file /.init_enable_core
exists, then init will call setrlimit() to allow unlimited
core file sizes. If this option is disabled, processes
will not generate any core files.
-config BUSYBOX_CONFIG_FEATURE_INITRD
- bool "Support running init from within an initrd (not initramfs)"
- default BUSYBOX_DEFAULT_FEATURE_INITRD
- depends on BUSYBOX_CONFIG_INIT
- help
- Legacy support for running init under the old-style initrd. Allows
- the name linuxrc to act as init, and it doesn't assume init is PID 1.
-
- This does not apply to initramfs, which runs /init as PID 1 and
- requires no special support.
-
config BUSYBOX_CONFIG_INIT_TERMINAL_TYPE
string "Initial terminal type"
default BUSYBOX_DEFAULT_INIT_TERMINAL_TYPE
- depends on BUSYBOX_CONFIG_INIT
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
help
This is the initial value set by init for the TERM environment
variable. This variable is used by programs which make use of
@@ -162,6 +162,21 @@ config BUSYBOX_CONFIG_INIT_TERMINAL_TYPE
Note that on Linux, init attempts to detect serial terminal and
sets TERM to "vt102" if one is found.
+
+config BUSYBOX_CONFIG_FEATURE_INIT_MODIFY_CMDLINE
+ bool "Modify the command-line to \"init\""
+ default BUSYBOX_DEFAULT_FEATURE_INIT_MODIFY_CMDLINE
+ depends on BUSYBOX_CONFIG_INIT || BUSYBOX_CONFIG_LINUXRC
+ help
+ When launched as PID 1 and after parsing its arguments, init
+ wipes all the arguments but argv[0] and rewrites argv[0] to
+ contain only "init", so that its command-line appears solely as
+ "init" in tools such as ps.
+ If this option is set to Y, init will keep its original behavior,
+ otherwise, all the arguments including argv[0] will be preserved,
+ be they parsed or ignored by init.
+ The original command-line used to launch init can then be
+ retrieved in /proc/1/cmdline on Linux, for example.
config BUSYBOX_CONFIG_MESG
bool "mesg"
default BUSYBOX_DEFAULT_MESG
diff --git a/package/utils/busybox/config/libbb/Config.in b/package/utils/busybox/config/libbb/Config.in
index e66a15b692..0695f9ba39 100644
--- a/package/utils/busybox/config/libbb/Config.in
+++ b/package/utils/busybox/config/libbb/Config.in
@@ -6,14 +6,38 @@
menu "Busybox Library Tuning"
-config BUSYBOX_CONFIG_FEATURE_SYSTEMD
- bool "Enable systemd support"
- default BUSYBOX_DEFAULT_FEATURE_SYSTEMD
- help
- If you plan to use busybox daemons on a system where daemons
- are controlled by systemd, enable this option.
- If you don't use systemd, it is still safe to enable it,
- but the downside is increased code size.
+config BUSYBOX_CONFIG_FEATURE_USE_BSS_TAIL
+ bool "Use the end of BSS page"
+ default BUSYBOX_DEFAULT_FEATURE_USE_BSS_TAIL
+ help
+ Attempt to reclaim a small unused part of BSS.
+
+ Executables have the following parts:
+ = read-only executable code and constants, also known as "text"
+ = read-write data
+ = non-initialized (zeroed on demand) data, also known as "bss"
+
+ At link time, "text" is padded to a full page. At runtime, all "text"
+ pages are mapped RO and executable.
+ "Data" starts on the next page boundary, but is not padded
+ to a full page at the end. "Bss" starts wherever "data" ends.
+ At runtime, "data" pages are mapped RW and they are file-backed
+ (this includes a small portion of "bss" which may live in the last
+ partial page of "data").
+ Pages which are fully in "bss" are mapped to anonymous memory.
+
+ "Bss" end is usually not page-aligned. There is an unused space
+ in the last page. Linker marks its start with the "_end" symbol.
+
+ This option will attempt to use that space for bb_common_bufsiz1[]
+ array. If it fits after _end, it will be used, and COMMON_BUFSIZE
+ will be enlarged from its guaranteed minimum size of 1 kbyte.
+ This may require recompilation a second time, since value of _end
+ is known only after final link.
+
+ If you are getting a build error like this:
+ appletlib.c:(.text.main+0xd): undefined reference to '_end'
+ disable this option.
config BUSYBOX_CONFIG_FEATURE_RTMINMAX
bool "Support RTMIN[+n] and RTMAX[-n] signal names"
default BUSYBOX_DEFAULT_FEATURE_RTMINMAX
@@ -30,7 +54,7 @@ config BUSYBOX_CONFIG_PASSWORD_MINLEN
config BUSYBOX_CONFIG_MD5_SMALL
int "MD5: Trade bytes for speed (0:fast, 3:slow)"
- default BUSYBOX_DEFAULT_MD5_SMALL
+ default BUSYBOX_DEFAULT_MD5_SMALL # all "fast or small" options default to small
range 0 3
help
Trade binary size versus speed for the md5sum algorithm.
@@ -44,7 +68,7 @@ config BUSYBOX_CONFIG_MD5_SMALL
config BUSYBOX_CONFIG_SHA3_SMALL
int "SHA3: Trade bytes for speed (0:fast, 1:slow)"
- default BUSYBOX_DEFAULT_SHA3_SMALL
+ default BUSYBOX_DEFAULT_SHA3_SMALL # all "fast or small" options default to small
range 0 1
help
Trade binary size versus speed for the sha3sum algorithm.
@@ -54,7 +78,7 @@ config BUSYBOX_CONFIG_SHA3_SMALL
config BUSYBOX_CONFIG_FEATURE_FAST_TOP
bool "Faster /proc scanning code (+100 bytes)"
- default BUSYBOX_DEFAULT_FEATURE_FAST_TOP
+ default BUSYBOX_DEFAULT_FEATURE_FAST_TOP # all "fast or small" options default to small
help
This option makes top (and ps) ~20% faster (or 20% less CPU hungry),
but code size is slightly bigger.
@@ -128,7 +152,7 @@ config BUSYBOX_CONFIG_FEATURE_EDITING_SAVE_ON_EXIT
config BUSYBOX_CONFIG_FEATURE_REVERSE_SEARCH
bool "Reverse history search"
default BUSYBOX_DEFAULT_FEATURE_REVERSE_SEARCH
- depends on BUSYBOX_CONFIG_FEATURE_EDITING_SAVEHISTORY
+ depends on BUSYBOX_CONFIG_FEATURE_EDITING
help
Enable readline-like Ctrl-R combination for reverse history search.
Increases code by about 0.5k.
diff --git a/package/utils/busybox/config/loginutils/Config.in b/package/utils/busybox/config/loginutils/Config.in
index f5ecf6f23b..956115c7f4 100644
--- a/package/utils/busybox/config/loginutils/Config.in
+++ b/package/utils/busybox/config/loginutils/Config.in
@@ -6,18 +6,6 @@
menu "Login/Password Management Utilities"
-config BUSYBOX_CONFIG_ADD_SHELL
- bool "add-shell"
- default BUSYBOX_DEFAULT_ADD_SHELL if BUSYBOX_CONFIG_DESKTOP
- help
- Add shells to /etc/shells.
-
-config BUSYBOX_CONFIG_REMOVE_SHELL
- bool "remove-shell"
- default BUSYBOX_DEFAULT_REMOVE_SHELL if BUSYBOX_CONFIG_DESKTOP
- help
- Remove shells from /etc/shells.
-
config BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS
bool "Support for shadow passwords"
default BUSYBOX_DEFAULT_FEATURE_SHADOWPASSWDS
@@ -104,6 +92,38 @@ config BUSYBOX_CONFIG_USE_BB_CRYPT_SHA
With this option off, login will fail password check for any
user which has password encrypted with these algorithms.
+config BUSYBOX_CONFIG_ADD_SHELL
+ bool "add-shell"
+ default BUSYBOX_DEFAULT_ADD_SHELL if BUSYBOX_CONFIG_DESKTOP
+ help
+ Add shells to /etc/shells.
+
+config BUSYBOX_CONFIG_REMOVE_SHELL
+ bool "remove-shell"
+ default BUSYBOX_DEFAULT_REMOVE_SHELL if BUSYBOX_CONFIG_DESKTOP
+ help
+ Remove shells from /etc/shells.
+config BUSYBOX_CONFIG_ADDGROUP
+ bool "addgroup"
+ default BUSYBOX_DEFAULT_ADDGROUP
+ help
+ Utility for creating a new group account.
+
+config BUSYBOX_CONFIG_FEATURE_ADDGROUP_LONG_OPTIONS
+ bool "Enable long options"
+ default BUSYBOX_DEFAULT_FEATURE_ADDGROUP_LONG_OPTIONS
+ depends on BUSYBOX_CONFIG_ADDGROUP && BUSYBOX_CONFIG_LONG_OPTS
+ help
+ Support long options for the addgroup applet.
+
+config BUSYBOX_CONFIG_FEATURE_ADDUSER_TO_GROUP
+ bool "Support for adding users to groups"
+ default BUSYBOX_DEFAULT_FEATURE_ADDUSER_TO_GROUP
+ depends on BUSYBOX_CONFIG_ADDGROUP
+ help
+ If called with two non-option arguments,
+ addgroup will add an existing user to an
+ existing group.
config BUSYBOX_CONFIG_ADDUSER
bool "adduser"
default BUSYBOX_DEFAULT_ADDUSER
@@ -151,29 +171,33 @@ config BUSYBOX_CONFIG_LAST_SYSTEM_ID
default BUSYBOX_DEFAULT_LAST_SYSTEM_ID
help
Last valid system uid or gid for adduser and addgroup
-
-config BUSYBOX_CONFIG_ADDGROUP
- bool "addgroup"
- default BUSYBOX_DEFAULT_ADDGROUP
+config BUSYBOX_CONFIG_CHPASSWD
+ bool "chpasswd"
+ default BUSYBOX_DEFAULT_CHPASSWD
help
- Utility for creating a new group account.
+ Reads a file of user name and password pairs from standard input
+ and uses this information to update a group of existing users.
-config BUSYBOX_CONFIG_FEATURE_ADDGROUP_LONG_OPTIONS
- bool "Enable long options"
- default BUSYBOX_DEFAULT_FEATURE_ADDGROUP_LONG_OPTIONS
- depends on BUSYBOX_CONFIG_ADDGROUP && BUSYBOX_CONFIG_LONG_OPTS
+config BUSYBOX_CONFIG_FEATURE_DEFAULT_PASSWD_ALGO
+ string "Default password encryption method (passwd -a, cryptpw -m parameter)"
+ default BUSYBOX_DEFAULT_FEATURE_DEFAULT_PASSWD_ALGO
+ depends on BUSYBOX_CONFIG_PASSWD || BUSYBOX_CONFIG_CRYPTPW
help
- Support long options for the addgroup applet.
-
-config BUSYBOX_CONFIG_FEATURE_ADDUSER_TO_GROUP
- bool "Support for adding users to groups"
- default BUSYBOX_DEFAULT_FEATURE_ADDUSER_TO_GROUP
- depends on BUSYBOX_CONFIG_ADDGROUP
+ Possible choices are "d[es]", "m[d5]", "s[ha256]" or "sha512".
+config BUSYBOX_CONFIG_CRYPTPW
+ bool "cryptpw"
+ default BUSYBOX_DEFAULT_CRYPTPW
help
- If called with two non-option arguments,
- addgroup will add an existing user to an
- existing group.
+ Encrypts the given password with the crypt(3) libc function
+ using the given salt.
+config BUSYBOX_CONFIG_MKPASSWD
+ bool "mkpasswd"
+ default BUSYBOX_DEFAULT_MKPASSWD
+ help
+ Encrypts the given password with the crypt(3) libc function
+ using the given salt. Debian has this utility under mkpasswd
+ name. Busybox provides mkpasswd as an alias for cryptpw.
config BUSYBOX_CONFIG_DELUSER
bool "deluser"
default BUSYBOX_DEFAULT_DELUSER
@@ -193,7 +217,6 @@ config BUSYBOX_CONFIG_FEATURE_DEL_USER_FROM_GROUP
help
If called with two non-option arguments, deluser
or delgroup will remove an user from a specified group.
-
config BUSYBOX_CONFIG_GETTY
bool "getty"
default BUSYBOX_DEFAULT_GETTY
@@ -212,7 +235,6 @@ config BUSYBOX_CONFIG_GETTY
printf "%s login: " "`hostname`"
read -r login
exec /bin/login "$login"
-
config BUSYBOX_CONFIG_LOGIN
bool "login"
default BUSYBOX_DEFAULT_LOGIN
@@ -258,7 +280,6 @@ config BUSYBOX_CONFIG_FEATURE_SECURETTY
The file /etc/securetty is used by (some versions of) login(1).
The file contains the device names of tty lines (one per line,
without leading /dev/) on which root is allowed to login.
-
config BUSYBOX_CONFIG_PASSWD
bool "passwd"
default BUSYBOX_DEFAULT_PASSWD
@@ -278,29 +299,6 @@ config BUSYBOX_CONFIG_FEATURE_PASSWD_WEAK_CHECK
depends on BUSYBOX_CONFIG_PASSWD
help
With this option passwd will refuse new passwords which are "weak".
-
-config BUSYBOX_CONFIG_CRYPTPW
- bool "cryptpw"
- default BUSYBOX_DEFAULT_CRYPTPW
- help
- Encrypts the given password with the crypt(3) libc function
- using the given salt. Debian has this utility under mkpasswd
- name. Busybox provides mkpasswd as an alias for cryptpw.
-
-config BUSYBOX_CONFIG_CHPASSWD
- bool "chpasswd"
- default BUSYBOX_DEFAULT_CHPASSWD
- help
- Reads a file of user name and password pairs from standard input
- and uses this information to update a group of existing users.
-
-config BUSYBOX_CONFIG_FEATURE_DEFAULT_PASSWD_ALGO
- string "Default password encryption method (passwd -a, cryptpw -m parameter)"
- default BUSYBOX_DEFAULT_FEATURE_DEFAULT_PASSWD_ALGO
- depends on BUSYBOX_CONFIG_PASSWD || BUSYBOX_CONFIG_CRYPTPW
- help
- Possible choices are "d[es]", "m[d5]", "s[ha256]" or "sha512".
-
config BUSYBOX_CONFIG_SU
bool "su"
default BUSYBOX_DEFAULT_SU
@@ -321,7 +319,6 @@ config BUSYBOX_CONFIG_FEATURE_SU_CHECKS_SHELLS
bool "Enable su to check user's shell to be listed in /etc/shells"
depends on BUSYBOX_CONFIG_SU
default BUSYBOX_DEFAULT_FEATURE_SU_CHECKS_SHELLS
-
config BUSYBOX_CONFIG_SULOGIN
bool "sulogin"
default BUSYBOX_DEFAULT_SULOGIN
@@ -329,7 +326,6 @@ config BUSYBOX_CONFIG_SULOGIN
help
sulogin is invoked when the system goes into single user
mode (this is done through an entry in inittab).
-
config BUSYBOX_CONFIG_VLOCK
bool "vlock"
default BUSYBOX_DEFAULT_VLOCK
diff --git a/package/utils/busybox/config/miscutils/Config.in b/package/utils/busybox/config/miscutils/Config.in
index c6deaafb62..3465df40ab 100644
--- a/package/utils/busybox/config/miscutils/Config.in
+++ b/package/utils/busybox/config/miscutils/Config.in
@@ -246,6 +246,12 @@ config BUSYBOX_CONFIG_UBIUPDATEVOL
select BUSYBOX_CONFIG_PLATFORM_LINUX
help
Update a UBI volume.
+config BUSYBOX_CONFIG_UBIRENAME
+ bool "ubirename"
+ default BUSYBOX_DEFAULT_UBIRENAME
+ select BUSYBOX_CONFIG_PLATFORM_LINUX
+ help
+ Utility to rename UBI volumes
config BUSYBOX_CONFIG_WALL
bool "wall"
default BUSYBOX_DEFAULT_WALL
@@ -554,23 +560,13 @@ config BUSYBOX_CONFIG_LAST
help
'last' displays a list of the last users that logged into the system.
-choice
- prompt "Choose last implementation"
- depends on BUSYBOX_CONFIG_LAST
- default BUSYBOX_CONFIG_FEATURE_LAST_FANCY
-
-config BUSYBOX_CONFIG_FEATURE_LAST_SMALL
- bool "small"
- help
- This is a small version of last with just the basic set of
- features.
-
config BUSYBOX_CONFIG_FEATURE_LAST_FANCY
- bool "huge"
+ bool "Turn on output of extra information"
+ default BUSYBOX_DEFAULT_FEATURE_LAST_FANCY
+ depends on BUSYBOX_CONFIG_LAST
help
'last' displays detailed information about the last users that
logged into the system (mimics sysvinit last). +900 bytes.
-endchoice
config BUSYBOX_CONFIG_HDPARM
bool "hdparm"
diff --git a/package/utils/busybox/config/modutils/Config.in b/package/utils/busybox/config/modutils/Config.in
index 9add56ef66..8e0e2af9ef 100644
--- a/package/utils/busybox/config/modutils/Config.in
+++ b/package/utils/busybox/config/modutils/Config.in
@@ -44,9 +44,6 @@ config BUSYBOX_CONFIG_MODPROBE_SMALL
- rmmod is an alias to modprobe -r
- depmod generates modules.dep.bb
- As of 2008-07, this code is experimental. It is 14kb smaller
- than "non-small" modutils.
-
config BUSYBOX_CONFIG_FEATURE_MODPROBE_SMALL_OPTIONS_ON_CMDLINE
bool "Accept module options on modprobe command line"
default BUSYBOX_DEFAULT_FEATURE_MODPROBE_SMALL_OPTIONS_ON_CMDLINE
diff --git a/package/utils/busybox/config/networking/Config.in b/package/utils/busybox/config/networking/Config.in
index 7e5a414a68..407ddd30dd 100644
--- a/package/utils/busybox/config/networking/Config.in
+++ b/package/utils/busybox/config/networking/Config.in
@@ -673,7 +673,7 @@ config BUSYBOX_CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_CHARGEN
config BUSYBOX_CONFIG_FEATURE_INETD_RPC
bool "Support RPC services"
- default BUSYBOX_DEFAULT_FEATURE_INETD_RPC
+ default BUSYBOX_DEFAULT_FEATURE_INETD_RPC # very rarely used, and needs Sun RPC support in libc
depends on BUSYBOX_CONFIG_INETD
select BUSYBOX_CONFIG_FEATURE_HAVE_RPC
help
@@ -730,6 +730,13 @@ config BUSYBOX_CONFIG_FEATURE_IP_RULE
help
Add support for rule commands to "ip".
+config BUSYBOX_CONFIG_FEATURE_IP_NEIGH
+ bool "ip neighbor"
+ default BUSYBOX_DEFAULT_FEATURE_IP_NEIGH
+ depends on BUSYBOX_CONFIG_IP
+ help
+ Add support for neighbor commands to "ip".
+
config BUSYBOX_CONFIG_FEATURE_IP_SHORT_FORMS
bool "Support short forms of ip commands"
default BUSYBOX_DEFAULT_FEATURE_IP_SHORT_FORMS
@@ -741,6 +748,7 @@ config BUSYBOX_CONFIG_FEATURE_IP_SHORT_FORMS
ip route -> iproute
ip tunnel -> iptunnel
ip rule -> iprule
+ ip neigh -> ipneigh
Say N unless you desparately need the short form of the ip
object commands.
@@ -780,6 +788,11 @@ config BUSYBOX_CONFIG_IPRULE
default BUSYBOX_DEFAULT_IPRULE
depends on BUSYBOX_CONFIG_FEATURE_IP_SHORT_FORMS && BUSYBOX_CONFIG_FEATURE_IP_RULE
+config BUSYBOX_CONFIG_IPNEIGH
+ bool
+ default BUSYBOX_DEFAULT_IPNEIGH
+ depends on BUSYBOX_CONFIG_FEATURE_IP_SHORT_FORMS && BUSYBOX_CONFIG_FEATURE_IP_NEIGH
+
config BUSYBOX_CONFIG_IPCALC
bool "ipcalc"
default BUSYBOX_DEFAULT_IPCALC
diff --git a/package/utils/busybox/config/printutils/Config.in b/package/utils/busybox/config/printutils/Config.in
index cccc4a541f..3a2baa311d 100644
--- a/package/utils/busybox/config/printutils/Config.in
+++ b/package/utils/busybox/config/printutils/Config.in
@@ -6,13 +6,11 @@
menu "Print Utilities"
-
config BUSYBOX_CONFIG_LPD
bool "lpd"
default BUSYBOX_DEFAULT_LPD
help
lpd is a print spooling daemon.
-
config BUSYBOX_CONFIG_LPR
bool "lpr"
default BUSYBOX_DEFAULT_LPR
diff --git a/package/utils/busybox/config/runit/Config.in b/package/utils/busybox/config/runit/Config.in
index 8074fb18f7..a322a2cd8a 100644
--- a/package/utils/busybox/config/runit/Config.in
+++ b/package/utils/busybox/config/runit/Config.in
@@ -6,14 +6,43 @@
menu "Runit Utilities"
+config BUSYBOX_CONFIG_CHPST
+ bool "chpst"
+ default BUSYBOX_DEFAULT_CHPST
+ help
+ chpst changes the process state according to the given options, and
+ execs specified program.
+config BUSYBOX_CONFIG_SETUIDGID
+ bool "setuidgid"
+ default BUSYBOX_DEFAULT_SETUIDGID
+ help
+ Sets soft resource limits as specified by options
+
+config BUSYBOX_CONFIG_ENVUIDGID
+ bool "envuidgid"
+ default BUSYBOX_DEFAULT_ENVUIDGID
+ help
+ Sets $UID to account's uid and $GID to account's gid
+
+config BUSYBOX_CONFIG_ENVDIR
+ bool "envdir"
+ default BUSYBOX_DEFAULT_ENVDIR
+ help
+ Sets various environment variables as specified by files
+ in the given directory
+
+config BUSYBOX_CONFIG_SOFTLIMIT
+ bool "softlimit"
+ default BUSYBOX_DEFAULT_SOFTLIMIT
+ help
+ Sets soft resource limits as specified by options
config BUSYBOX_CONFIG_RUNSV
bool "runsv"
default BUSYBOX_DEFAULT_RUNSV
help
runsv starts and monitors a service and optionally an appendant log
service.
-
config BUSYBOX_CONFIG_RUNSVDIR
bool "runsvdir"
default BUSYBOX_DEFAULT_RUNSVDIR
@@ -30,7 +59,6 @@ config BUSYBOX_CONFIG_FEATURE_RUNSVDIR_LOG
Enable feature where second parameter of runsvdir holds last error
message (viewable via top/ps). Otherwise (feature is off
or no parameter), error messages go to stderr only.
-
config BUSYBOX_CONFIG_SV
bool "sv"
default BUSYBOX_DEFAULT_SV
@@ -45,7 +73,6 @@ config BUSYBOX_CONFIG_SV_DEFAULT_SERVICE_DIR
help
Default directory for services.
Defaults to "/var/service"
-
config BUSYBOX_CONFIG_SVLOGD
bool "svlogd"
default BUSYBOX_DEFAULT_SVLOGD
@@ -54,36 +81,4 @@ config BUSYBOX_CONFIG_SVLOGD
filters log messages, and writes the data to one or more automatically
rotated logs.
-config BUSYBOX_CONFIG_CHPST
- bool "chpst"
- default BUSYBOX_DEFAULT_CHPST
- help
- chpst changes the process state according to the given options, and
- execs specified program.
-
-config BUSYBOX_CONFIG_SETUIDGID
- bool "setuidgid"
- default BUSYBOX_DEFAULT_SETUIDGID
- help
- Sets soft resource limits as specified by options
-
-config BUSYBOX_CONFIG_ENVUIDGID
- bool "envuidgid"
- default BUSYBOX_DEFAULT_ENVUIDGID
- help
- Sets $UID to account's uid and $GID to account's gid
-
-config BUSYBOX_CONFIG_ENVDIR
- bool "envdir"
- default BUSYBOX_DEFAULT_ENVDIR
- help
- Sets various environment variables as specified by files
- in the given directory
-
-config BUSYBOX_CONFIG_SOFTLIMIT
- bool "softlimit"
- default BUSYBOX_DEFAULT_SOFTLIMIT
- help
- Sets soft resource limits as specified by options
-
endmenu
diff --git a/package/utils/busybox/config/sysklogd/Config.in b/package/utils/busybox/config/sysklogd/Config.in
index de36a1e892..5fcee2c7ff 100644
--- a/package/utils/busybox/config/sysklogd/Config.in
+++ b/package/utils/busybox/config/sysklogd/Config.in
@@ -6,6 +6,64 @@
menu "System Logging Utilities"
+config BUSYBOX_CONFIG_KLOGD
+ bool "klogd"
+ default BUSYBOX_DEFAULT_KLOGD
+ help
+ klogd is a utility which intercepts and logs all
+ messages from the Linux kernel and sends the messages
+ out to the 'syslogd' utility so they can be logged. If
+ you wish to record the messages produced by the kernel,
+ you should enable this option.
+
+comment "klogd should not be used together with syslog to kernel printk buffer"
+ depends on BUSYBOX_CONFIG_KLOGD && BUSYBOX_CONFIG_FEATURE_KMSG_SYSLOG
+
+config BUSYBOX_CONFIG_FEATURE_KLOGD_KLOGCTL
+ bool "Use the klogctl() interface"
+ default BUSYBOX_DEFAULT_FEATURE_KLOGD_KLOGCTL
+ depends on BUSYBOX_CONFIG_KLOGD
+ select BUSYBOX_CONFIG_PLATFORM_LINUX
+ help
+ The klogd applet supports two interfaces for reading
+ kernel messages. Linux provides the klogctl() interface
+ which allows reading messages from the kernel ring buffer
+ independently from the file system.
+
+ If you answer 'N' here, klogd will use the more portable
+ approach of reading them from /proc or a device node.
+ However, this method requires the file to be available.
+
+ If in doubt, say 'Y'.
+config BUSYBOX_CONFIG_LOGGER
+ bool "logger"
+ default BUSYBOX_DEFAULT_LOGGER
+ select BUSYBOX_CONFIG_FEATURE_SYSLOG
+ help
+ The logger utility allows you to send arbitrary text
+ messages to the system log (i.e. the 'syslogd' utility) so
+ they can be logged. This is generally used to help locate
+ problems that occur within programs and scripts.
+config BUSYBOX_CONFIG_LOGREAD
+ bool "logread"
+ default BUSYBOX_DEFAULT_LOGREAD
+ depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG
+ help
+ If you enabled Circular Buffer support, you almost
+ certainly want to enable this feature as well. This
+ utility will allow you to read the messages that are
+ stored in the syslogd circular buffer.
+
+config BUSYBOX_CONFIG_FEATURE_LOGREAD_REDUCED_LOCKING
+ bool "Double buffering"
+ default BUSYBOX_DEFAULT_FEATURE_LOGREAD_REDUCED_LOCKING
+ depends on BUSYBOX_CONFIG_LOGREAD
+ help
+ 'logread' ouput to slow serial terminals can have
+ side effects on syslog because of the semaphore.
+ This option make logread to double buffer copy
+ from circular buffer, minimizing semaphore
+ contention at some minor memory expense.
config BUSYBOX_CONFIG_SYSLOGD
bool "syslogd"
@@ -28,7 +86,7 @@ config BUSYBOX_CONFIG_FEATURE_ROTATE_LOGFILE
depends on BUSYBOX_CONFIG_SYSLOGD
help
This enables syslogd to rotate the message files
- on his own. No need to use an external rotatescript.
+ on his own. No need to use an external rotate script.
config BUSYBOX_CONFIG_FEATURE_REMOTE_LOG
bool "Remote Log support"
@@ -92,27 +150,6 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
This option sets the size of the circular buffer
used to record system log messages.
-config BUSYBOX_CONFIG_LOGREAD
- bool "logread"
- default BUSYBOX_DEFAULT_LOGREAD
- depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG
- help
- If you enabled Circular Buffer support, you almost
- certainly want to enable this feature as well. This
- utility will allow you to read the messages that are
- stored in the syslogd circular buffer.
-
-config BUSYBOX_CONFIG_FEATURE_LOGREAD_REDUCED_LOCKING
- bool "Double buffering"
- default BUSYBOX_DEFAULT_FEATURE_LOGREAD_REDUCED_LOCKING
- depends on BUSYBOX_CONFIG_LOGREAD
- help
- 'logread' ouput to slow serial terminals can have
- side effects on syslog because of the semaphore.
- This option make logread to double buffer copy
- from circular buffer, minimizing semaphore
- contention at some minor memory expense.
-
config BUSYBOX_CONFIG_FEATURE_KMSG_SYSLOG
bool "Linux kernel printk buffer support"
default BUSYBOX_DEFAULT_FEATURE_KMSG_SYSLOG
@@ -126,44 +163,4 @@ config BUSYBOX_CONFIG_FEATURE_KMSG_SYSLOG
NOTICE: Syslog facilities in log entries needs kernel 3.5+.
-config BUSYBOX_CONFIG_KLOGD
- bool "klogd"
- default BUSYBOX_DEFAULT_KLOGD
- help
- klogd is a utility which intercepts and logs all
- messages from the Linux kernel and sends the messages
- out to the 'syslogd' utility so they can be logged. If
- you wish to record the messages produced by the kernel,
- you should enable this option.
-
-comment "klogd should not be used together with syslog to kernel printk buffer"
- depends on BUSYBOX_CONFIG_KLOGD && BUSYBOX_CONFIG_FEATURE_KMSG_SYSLOG
-
-config BUSYBOX_CONFIG_FEATURE_KLOGD_KLOGCTL
- bool "Use the klogctl() interface"
- default BUSYBOX_DEFAULT_FEATURE_KLOGD_KLOGCTL
- depends on BUSYBOX_CONFIG_KLOGD
- select BUSYBOX_CONFIG_PLATFORM_LINUX
- help
- The klogd applet supports two interfaces for reading
- kernel messages. Linux provides the klogctl() interface
- which allows reading messages from the kernel ring buffer
- independently from the file system.
-
- If you answer 'N' here, klogd will use the more portable
- approach of reading them from /proc or a device node.
- However, this method requires the file to be available.
-
- If in doubt, say 'Y'.
-
-config BUSYBOX_CONFIG_LOGGER
- bool "logger"
- default BUSYBOX_DEFAULT_LOGGER
- select BUSYBOX_CONFIG_FEATURE_SYSLOG
- help
- The logger utility allows you to send arbitrary text
- messages to the system log (i.e. the 'syslogd' utility) so
- they can be logged. This is generally used to help locate
- problems that occur within programs and scripts.
-
endmenu
diff --git a/package/utils/busybox/config/util-linux/Config.in b/package/utils/busybox/config/util-linux/Config.in
index 017b1196a0..08bddf819a 100644
--- a/package/utils/busybox/config/util-linux/Config.in
+++ b/package/utils/busybox/config/util-linux/Config.in
@@ -6,6 +6,11 @@
menu "Linux System Utilities"
+config BUSYBOX_CONFIG_BLKDISCARD
+ bool "blkdiscard"
+ default BUSYBOX_DEFAULT_BLKDISCARD
+ help
+ blkdiscard discards sectors on a given device.
config BUSYBOX_CONFIG_BLOCKDEV
bool "blockdev"
default BUSYBOX_DEFAULT_BLOCKDEV
@@ -174,11 +179,34 @@ config BUSYBOX_CONFIG_FEATURE_MOUNT_OTHERTAB
default BUSYBOX_DEFAULT_FEATURE_MOUNT_OTHERTAB
help
Support mount -T (specifying an alternate fstab)
+config BUSYBOX_CONFIG_NSENTER
+ bool "nsenter"
+ default BUSYBOX_DEFAULT_NSENTER
+ select BUSYBOX_CONFIG_PLATFORM_LINUX
+ help
+ Run program with namespaces of other processes.
+
+config BUSYBOX_CONFIG_FEATURE_NSENTER_LONG_OPTS
+ bool "Enable long options"
+ default BUSYBOX_DEFAULT_FEATURE_NSENTER_LONG_OPTS
+ depends on BUSYBOX_CONFIG_NSENTER && BUSYBOX_CONFIG_LONG_OPTS
+ help
+ Support long options for the nsenter applet. This makes
+ the busybox implementation more compatible with upstream.
config BUSYBOX_CONFIG_REV
bool "rev"
default BUSYBOX_DEFAULT_REV
help
Reverse lines of a file or files.
+config BUSYBOX_CONFIG_SETARCH
+ bool "setarch"
+ default BUSYBOX_DEFAULT_SETARCH
+ select BUSYBOX_CONFIG_PLATFORM_LINUX
+ help
+ The linux32 utility is used to create a 32bit environment for the
+ specified program (usually a shell). It only makes sense to have
+ this util on a system that supports both 64bit and 32bit userland
+ (like amd64/x86, ppc64/ppc, sparc64/sparc, etc...).
config BUSYBOX_CONFIG_UEVENT
bool "uevent"
default BUSYBOX_DEFAULT_UEVENT
@@ -186,6 +214,13 @@ config BUSYBOX_CONFIG_UEVENT
help
uevent is a netlink listener for kernel uevent notifications
sent via netlink. It is usually used for dynamic device creation.
+config BUSYBOX_CONFIG_UNSHARE
+ bool "unshare"
+ default BUSYBOX_DEFAULT_UNSHARE
+ depends on BUSYBOX_CONFIG_LONG_OPTS && !BUSYBOX_CONFIG_NOMMU
+ select BUSYBOX_CONFIG_PLATFORM_LINUX
+ help
+ Run program with some namespaces unshared from parent.
config BUSYBOX_CONFIG_ACPID
bool "acpid"
@@ -669,16 +704,6 @@ config BUSYBOX_CONFIG_SCRIPTREPLAY
This program replays a typescript, using timing information
given by script -t.
-config BUSYBOX_CONFIG_SETARCH
- bool "setarch"
- default BUSYBOX_DEFAULT_SETARCH
- select BUSYBOX_CONFIG_PLATFORM_LINUX
- help
- The linux32 utility is used to create a 32bit environment for the
- specified program (usually a shell). It only makes sense to have
- this util on a system that supports both 64bit and 32bit userland
- (like amd64/x86, ppc64/ppc, sparc64/sparc, etc...).
-
config BUSYBOX_CONFIG_SWAPONOFF
bool "swaponoff"
default BUSYBOX_DEFAULT_SWAPONOFF
diff --git a/package/utils/busybox/config/util-linux/volume_id/Config.in b/package/utils/busybox/config/util-linux/volume_id/Config.in
index 306550b7b8..6153314d6f 100644
--- a/package/utils/busybox/config/util-linux/volume_id/Config.in
+++ b/package/utils/busybox/config/util-linux/volume_id/Config.in
@@ -12,6 +12,14 @@ menu "Filesystem/Volume identification"
depends on BUSYBOX_CONFIG_VOLUMEID
+config BUSYBOX_CONFIG_FEATURE_VOLUMEID_BCACHE
+ bool "bcache filesystem"
+ default BUSYBOX_DEFAULT_FEATURE_VOLUMEID_BCACHE
+ depends on BUSYBOX_CONFIG_VOLUMEID
+ help
+ TODO
+
+
config BUSYBOX_CONFIG_FEATURE_VOLUMEID_BTRFS
bool "btrfs filesystem"
default BUSYBOX_DEFAULT_FEATURE_VOLUMEID_BTRFS