summaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
Diffstat (limited to 'package/system')
-rw-r--r--package/system/opkg/Makefile2
-rw-r--r--package/system/opkg/patches/280-use-vfork.patch19
2 files changed, 8 insertions, 13 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 446463ec85..67ceb7cafc 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -109,7 +109,7 @@ endef
Package/opkg-smime/conffiles = $(Package/opkg/conffiles)
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -DOPKG_USE_VFORK=1
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CONFIGURE_ARGS += \
diff --git a/package/system/opkg/patches/280-use-vfork.patch b/package/system/opkg/patches/280-use-vfork.patch
index fc6058a701..1c46f52b02 100644
--- a/package/system/opkg/patches/280-use-vfork.patch
+++ b/package/system/opkg/patches/280-use-vfork.patch
@@ -1,25 +1,20 @@
--- a/libbb/gz_open.c
+++ b/libbb/gz_open.c
-@@ -29,7 +29,12 @@
+@@ -29,7 +29,7 @@
#include <unistd.h>
#include "libbb.h"
-+#ifdef OPKG_USE_VFORK
-+static const int gz_use_vfork = OPKG_USE_VFORK;
-+#else
- static int gz_use_vfork;
-+#endif
-+
+-static int gz_use_vfork;
++static const int gz_use_vfork = 1;
FILE *
gz_open(FILE *compressed_file, int *pid)
-@@ -38,7 +43,9 @@ gz_open(FILE *compressed_file, int *pid)
+@@ -38,8 +38,6 @@ gz_open(FILE *compressed_file, int *pid)
off_t floc;
int cfile = -1;
-+#ifndef OPKG_USE_VFORK
- gz_use_vfork = (getenv("OPKG_USE_VFORK") != NULL);
-+#endif
-
+- gz_use_vfork = (getenv("OPKG_USE_VFORK") != NULL);
+-
if (gz_use_vfork) {
/* Create a new file descriptor for the input stream
+ * (it *must* be associated with a file), and lseek()