summaryrefslogtreecommitdiffstats
path: root/package/spca5xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/spca5xx/Makefile')
-rw-r--r--package/spca5xx/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/spca5xx/Makefile b/package/spca5xx/Makefile
new file mode 100644
index 0000000000..643e5863f4
--- /dev/null
+++ b/package/spca5xx/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=spca5xx
+PKG_VERSION:=20060501
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
+PKG_MD5SUM:=8fcec25715aea10f9ebec5728c37e752
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+#FIXME: add proper dependency handling on kmod-usb-core & kmod-videodev packages
+define Package/kmod-spca5xx
+ SECTION:=kernel
+ CATEGORY:=Kernel drivers
+ DEPENDS:=@PACKAGE_KMOD_USB&&PACKAGE_KMOD_VIDEODEV
+ TITLE:=Driver for SPCA5xx based USB cameras
+ URL:=http://mxhaard.free.fr/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+
+define Build/Compile
+ $(MAKE) -C $(LINUX_DIR) \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ KERNELVERSION="$(KERNEL)" \
+ KERNEL_VERSION="$(LINUX_VERSION)" \
+ KERNELDIR="$(LINUX_DIR)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ modules
+endef
+
+define Package/kmod-spca5xx/install
+ install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
+ $(CP) $(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX) \
+ $(1)/lib/modules/$(LINUX_VERSION)/
+endef
+
+$(eval $(call BuildPackage,kmod-spca5xx))