summaryrefslogtreecommitdiffstats
path: root/package/spca5xx-le
diff options
context:
space:
mode:
Diffstat (limited to 'package/spca5xx-le')
-rw-r--r--package/spca5xx-le/Makefile41
-rw-r--r--package/spca5xx-le/patches/100-compile_pud_shift.patch21
-rw-r--r--package/spca5xx-le/patches/101-linux_2_6.patch13
3 files changed, 0 insertions, 75 deletions
diff --git a/package/spca5xx-le/Makefile b/package/spca5xx-le/Makefile
deleted file mode 100644
index 1e53821f35..0000000000
--- a/package/spca5xx-le/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: Makefile 7137 2007-05-08 18:40:02Z nbd $
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=spca5xx-le
-PKG_VERSION:=1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME).tar.bz2
-PKG_SOURCE_URL:=http://www.acmesystems.it/download/owrt/
-PKG_MD5SUM:=
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define KernelPackage/video-spca5xx-le
- SUBMENU:=Video Support
- TITLE:=SPCA5xx based USB webcam support (Light Edition)
- URL:=http://mxhaard.free.fr/
- DEPENDS:=@LINUX_2_6_23||LINUX_2_6_24||LINUX_2_6_25 @USB_SUPPORT +kmod-usb-core kmod-video-core
- FILES:=$(PKG_BUILD_DIR)/spca5xx.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,90,spca5xx)
-endef
-
-define Build/Compile
- $(MAKE) -C $(LINUX_DIR) \
- ARCH="$(LINUX_KARCH)" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- SUBDIRS="$(PKG_BUILD_DIR)" \
- modules
-endef
-
-$(eval $(call KernelPackage,video-spca5xx-le))
diff --git a/package/spca5xx-le/patches/100-compile_pud_shift.patch b/package/spca5xx-le/patches/100-compile_pud_shift.patch
deleted file mode 100644
index 91913a7993..0000000000
--- a/package/spca5xx-le/patches/100-compile_pud_shift.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur spca5xx-le/spca_core.c spca5xx-le-new/spca_core.c
---- spca5xx-le/spca_core.c 2007-06-03 21:30:29.000000000 +0100
-+++ spca5xx-le-new/spca_core.c 2008-01-06 12:48:08.000000000 +0000
-@@ -535,7 +535,7 @@
-
- if (!pgd_none (*pgd))
- {
--#if PUD_SHIFT
-+#ifdef PUD_SHIFT
- pud_t *pud = pud_offset (pgd, adr);
- if (!pud_none (*pud))
- {
-@@ -552,7 +552,7 @@
- ret = (unsigned long) page_address (pte_page (pte));
- ret |= (adr & (PAGE_SIZE - 1));
- }
--#if PUD_SHIFT
-+#ifdef PUD_SHIFT
- }
- #endif
- }
diff --git a/package/spca5xx-le/patches/101-linux_2_6.patch b/package/spca5xx-le/patches/101-linux_2_6.patch
deleted file mode 100644
index be0679f678..0000000000
--- a/package/spca5xx-le/patches/101-linux_2_6.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ruN spca5xx-le-orig/spca_core.c spca5xx-le/spca_core.c
---- spca5xx-le-orig/spca_core.c 2008-04-12 18:09:57.000000000 +0200
-+++ spca5xx-le/spca_core.c 2008-04-12 18:16:45.000000000 +0200
-@@ -2799,7 +2799,9 @@
- .owner = THIS_MODULE,
- .name = "SPCA5XX USB Camera",
- .type = VID_TYPE_CAPTURE,
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,23)
- .hardware = VID_HARDWARE_SPCA5XX,
-+#endif
- .fops = &spca5xx_fops,
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
- .release = video_device_release,