summaryrefslogtreecommitdiffstats
path: root/package/nvram/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/nvram/Makefile')
-rw-r--r--package/nvram/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/package/nvram/Makefile b/package/nvram/Makefile
new file mode 100644
index 0000000000..ab33c11514
--- /dev/null
+++ b/package/nvram/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nvram
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nvram
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=@LINUX_2_4_BRCM
+ TITLE:=Broadcom config utility
+ DESCRIPTION:=\
+ This package contains an utility to control broadcom's 'nvram' config \\\
+ area.
+endef
+
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)
+endef
+
+define Build/InstallDev
+ mkdir -p $(STAGING_DIR)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+ rm -f $(STAGING_DIR)/usr/lib/lib{nvram,shared}*.so
+endef
+
+define Package/nvram/install
+ install -d -m0755 $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
+ install -d -m0755 $(1)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,nvram))