summaryrefslogtreecommitdiffstats
path: root/package/network/utils/curl/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/curl/patches')
-rw-r--r--package/network/utils/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch45
-rw-r--r--package/network/utils/curl/patches/100-check_long_long.patch10
-rw-r--r--package/network/utils/curl/patches/200-no_docs_tests.patch22
-rw-r--r--package/network/utils/curl/patches/400-hugehelp.patch13
4 files changed, 90 insertions, 0 deletions
diff --git a/package/network/utils/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch b/package/network/utils/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch
new file mode 100644
index 0000000000..d7190af3ad
--- /dev/null
+++ b/package/network/utils/curl/patches/001-cyassl-Use-error-ssl.h-when-available.patch
@@ -0,0 +1,45 @@
+From 0204e17bc656e6c59b4010283e67f9251eb12c41 Mon Sep 17 00:00:00 2001
+From: Dan Fandrich <dan@coneharvesters.com>
+Date: Wed, 23 Apr 2014 11:01:30 +0200
+Subject: [PATCH] cyassl: Use error-ssl.h when available
+
+Versions since at least 2.9.4 renamed error.h to error-ssl.h, so use
+whichever one is available.
+---
+ configure.ac | 3 +++
+ lib/vtls/cyassl.c | 9 +++++++--
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -2003,6 +2003,9 @@ if test "$curl_ssl_msg" = "$init_ssl_msg
+ dnl cyassl/ctaocrypt/types.h needs SIZEOF_LONG_LONG defined!
+ AC_CHECK_SIZEOF(long long)
+
++ dnl Versions since at least 2.9.4 renamed error.h to error-ssl.h
++ AC_CHECK_HEADERS(cyassl/error-ssl.h)
++
+ LIBS="-lcyassl -lm $LIBS"
+
+ if test -n "$cyassllib"; then
+--- a/lib/vtls/cyassl.c
++++ b/lib/vtls/cyassl.c
+@@ -47,11 +47,16 @@
+ #define _MPRINTF_REPLACE /* use our functions only */
+ #include <curl/mprintf.h>
+ #include "curl_memory.h"
+-/* The last #include file should be: */
+-#include "memdebug.h"
++
+ #include <cyassl/ssl.h>
++#ifdef HAVE_CYASSL_ERROR_SSL_H
++#include <cyassl/error-ssl.h>
++#else
+ #include <cyassl/error.h>
++#endif
+
++/* The last #include file should be: */
++#include "memdebug.h"
+
+ static Curl_recv cyassl_recv;
+ static Curl_send cyassl_send;
diff --git a/package/network/utils/curl/patches/100-check_long_long.patch b/package/network/utils/curl/patches/100-check_long_long.patch
new file mode 100644
index 0000000000..7e014cd951
--- /dev/null
+++ b/package/network/utils/curl/patches/100-check_long_long.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -2904,6 +2904,7 @@ CURL_VERIFY_RUNTIMELIBS
+
+ AC_CHECK_SIZEOF(size_t)
+ AC_CHECK_SIZEOF(long)
++AC_CHECK_SIZEOF(long long)
+ AC_CHECK_SIZEOF(int)
+ AC_CHECK_SIZEOF(short)
+ CURL_CONFIGURE_LONG
diff --git a/package/network/utils/curl/patches/200-no_docs_tests.patch b/package/network/utils/curl/patches/200-no_docs_tests.patch
new file mode 100644
index 0000000000..2287215ed5
--- /dev/null
+++ b/package/network/utils/curl/patches/200-no_docs_tests.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -66,7 +66,7 @@ CLEANFILES = $(VC6LIBDSP) $(VC8LIBPRJ)
+ bin_SCRIPTS = curl-config
+
+ SUBDIRS = lib src include
+-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
++DIST_SUBDIRS = $(SUBDIRS) packages
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libcurl.pc
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -506,7 +506,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
+ CLEANFILES = $(VC6LIBDSP) $(VC8LIBPRJ)
+ bin_SCRIPTS = curl-config
+ SUBDIRS = lib src include
+-DIST_SUBDIRS = $(SUBDIRS) tests packages docs
++DIST_SUBDIRS = $(SUBDIRS) packages
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libcurl.pc
+ VSOURCES = vtls/openssl.c vtls/gtls.c vtls/vtls.c vtls/nss.c vtls/qssl.c \
diff --git a/package/network/utils/curl/patches/400-hugehelp.patch b/package/network/utils/curl/patches/400-hugehelp.patch
new file mode 100644
index 0000000000..312792be98
--- /dev/null
+++ b/package/network/utils/curl/patches/400-hugehelp.patch
@@ -0,0 +1,13 @@
+--- a/src/tool_hugehelp.h
++++ b/src/tool_hugehelp.h
+@@ -23,6 +23,10 @@
+ ***************************************************************************/
+ #include "tool_setup.h"
+
++#ifdef USE_MANUAL
+ void hugehelp(void);
++#else
++#define hugehelp() Curl_nop_stmt
++#endif
+
+ #endif /* HEADER_CURL_TOOL_HUGEHELP_H */