summaryrefslogtreecommitdiffstats
path: root/package/network/config/swconfig/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/config/swconfig/src/Makefile')
-rw-r--r--package/network/config/swconfig/src/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/package/network/config/swconfig/src/Makefile b/package/network/config/swconfig/src/Makefile
index 0d56f43156..1176bf0e40 100644
--- a/package/network/config/swconfig/src/Makefile
+++ b/package/network/config/swconfig/src/Makefile
@@ -6,7 +6,10 @@ LIBS=-lnl -lnl-genl
all: swconfig
%.o: %.c
- $(CC) $(CFLAGS) -c -o $@ $^
+ $(CC) $(CFLAGS) -fPIC -c -o $@ $^
-swconfig: cli.o swlib.o uci.o
- $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+libsw.so: swlib.o
+ $(CC) $(CFLAGS) -fPIC -shared -o $@ swlib.o
+
+swconfig: libsw.so cli.o uci.o
+ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS) -L./ -lsw