summaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/008-led_default.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/mac80211/patches/008-led_default.patch')
-rw-r--r--package/mac80211/patches/008-led_default.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/package/mac80211/patches/008-led_default.patch b/package/mac80211/patches/008-led_default.patch
index a392e500ef..5f6eec0366 100644
--- a/package/mac80211/patches/008-led_default.patch
+++ b/package/mac80211/patches/008-led_default.patch
@@ -1,7 +1,7 @@
--- a/config.mk
+++ b/config.mk
-@@ -115,7 +115,7 @@ CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstr
- # CONFIG_MAC80211_RC_PID=y
+@@ -132,7 +132,7 @@ CONFIG_COMPAT_MAC80211_RC_DEFAULT=minstr
+ CONFIG_MAC80211_RC_PID=y
CONFIG_MAC80211_RC_MINSTREL=y
CONFIG_MAC80211_RC_MINSTREL_HT=y
-CONFIG_MAC80211_LEDS=y
@@ -9,16 +9,16 @@
# enable mesh networking too
CONFIG_MAC80211_MESH=y
-@@ -218,7 +218,7 @@ CONFIG_B43_PCI_AUTOSELECT=y
- ifneq ($(CONFIG_PCMCIA),)
- # CONFIG_B43_PCMCIA=y
- endif
+@@ -233,7 +233,7 @@ CONFIG_B43_PCI_AUTOSELECT=y
+ ifdef CONFIG_PCMCIA
+ CONFIG_B43_PCMCIA=y
+ endif #CONFIG_PCMCIA
-CONFIG_B43_LEDS=y
+# CONFIG_B43_LEDS=y
CONFIG_B43_PHY_LP=y
- # CONFIG_B43_NPHY is not set
+ CONFIG_B43_NPHY=y
# CONFIG_B43_FORCE_PIO=y
-@@ -227,7 +227,7 @@ CONFIG_B43_PHY_LP=y
+@@ -242,7 +242,7 @@ CONFIG_B43_NPHY=y
CONFIG_B43LEGACY=m
CONFIG_B43LEGACY_HWRNG=y
CONFIG_B43LEGACY_PCI_AUTOSELECT=y
@@ -27,7 +27,7 @@
# CONFIG_B43LEGACY_DEBUG=y
CONFIG_B43LEGACY_DMA=y
CONFIG_B43LEGACY_PIO=y
-@@ -499,7 +499,7 @@ endif
+@@ -529,7 +529,7 @@ endif
# p54
CONFIG_P54_COMMON=m
@@ -81,7 +81,7 @@
void ath_deinit_leds(struct ath_softc *sc)
--- a/drivers/net/wireless/ath/ath9k/htc_drv_main.c
+++ b/drivers/net/wireless/ath/ath9k/htc_drv_main.c
-@@ -872,6 +872,7 @@ static void ath9k_led_brightness_work(st
+@@ -871,6 +871,7 @@ static void ath9k_led_brightness_work(st
}
}
@@ -89,7 +89,7 @@
static void ath9k_led_brightness(struct led_classdev *led_cdev,
enum led_brightness brightness)
{
-@@ -883,6 +884,7 @@ static void ath9k_led_brightness(struct
+@@ -882,6 +883,7 @@ static void ath9k_led_brightness(struct
ieee80211_queue_delayed_work(priv->hw,
&led->brightness_work, 0);
}
@@ -97,7 +97,7 @@
static void ath9k_led_stop_brightness(struct ath9k_htc_priv *priv)
{
-@@ -895,6 +897,7 @@ static void ath9k_led_stop_brightness(st
+@@ -894,6 +896,7 @@ static void ath9k_led_stop_brightness(st
static int ath9k_register_led(struct ath9k_htc_priv *priv, struct ath_led *led,
char *trigger)
{
@@ -105,7 +105,7 @@
int ret;
led->priv = priv;
-@@ -912,14 +915,19 @@ static int ath9k_register_led(struct ath
+@@ -911,14 +914,19 @@ static int ath9k_register_led(struct ath
INIT_DELAYED_WORK(&led->brightness_work, ath9k_led_brightness_work);
return ret;