summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 79b01c16c7..838526939f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -541,6 +541,22 @@ endef
$(eval $(call KernelPackage,scx200-wdt))
+define KernelPackage/sc520-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Natsemi SC520 Watchdog support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_SC520_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sc520_wdt.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,sc520_wdt)
+endef
+
+define KernelPackage/sc520-wdt/description
+ Kernel module for SC520 Watchdog
+endef
+
+$(eval $(call KernelPackage,sc520-wdt))
+
+
define KernelPackage/input-core
SUBMENU:=$(OTHER_MENU)
TITLE:=Input device core