summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/usb.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 8d1cee15da..5fd263567f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -42,6 +42,8 @@ define KernelPackage/musb-hdrc
CONFIG_USB_MUSB_HDRC \
CONFIG_MUSB_PIO_ONLY=n \
CONFIG_USB_MUSB_DUAL_ROLE=y \
+ CONFIG_USB_MUSB_GADGET=n \
+ CONFIG_USB_MUSB_HOST=n \
CONFIG_USB_MUSB_DEBUG=y
DEPENDS:=@(TARGET_omap||TARGET_omap24xx)
FILES:=$(LINUX_DIR)/drivers/usb/musb/musb_hdrc.ko