summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5af311df66..b1f4744330 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+ TITLE:=Gateworks GSC monitoring support
+ KCONFIG:=CONFIG_SENSORS_GSC
+ FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+ AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+ Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))