summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/block.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 3e22c458bb..37c1045eea 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -66,6 +66,21 @@ endef
$(eval $(call KernelPackage,ata-artop))
+define KernelPackage/ata-octeon-cf
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=Octeon Compact Flash support
+ DEPENDS:=kmod-ata-core @TARGET_octeon
+ KCONFIG:=CONFIG_PATA_OCTEON_CF
+ FILES:=$(LINUX_DIR)/drivers/ata/pata_octeon_cf.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,41,pata_octeon_cf)
+endef
+
+define KernelPackage/ata-octeon-cf/description
+ Octeon Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-octeon-cf))
+
define KernelPackage/ata-ixp4xx-cf
SUBMENU:=$(BLOCK_MENU)