summaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/usb.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 487a17de10..d47c552f5f 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -486,8 +486,10 @@ define KernelPackage/usb-dwc2
CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n \
CONFIG_USB_DWC2_DEBUG_PERIODIC=n
FILES:= \
- $(LINUX_DIR)/drivers/usb/dwc2/dwc2.ko \
- $(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko
+ $(LINUX_DIR)/drivers/usb/dwc2/dwc2.ko
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko
+ endif
AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform,1)
$(call AddDepends/usb)
endef