summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index e52dab6da1..587229d004 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -1041,3 +1041,18 @@ define KernelPackage/9pnet/description
endef
$(eval $(call KernelPackage,9pnet))
+
+
+define KernelPackage/nlmon
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Virtual netlink monitoring device
+ KCONFIG:=CONFIG_NLMON
+ FILES:=$(LINUX_DIR)/drivers/net/nlmon.ko
+ AUTOLOAD:=$(call AutoProbe,nlmon)
+endef
+
+define KernelPackage/nlmon/description
+ Kernel module which adds a monitoring device for netlink.
+endef
+
+$(eval $(call KernelPackage,nlmon))