summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index c68be90ad2..e52dab6da1 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -148,7 +148,9 @@ $(eval $(call KernelPackage,8021q))
define KernelPackage/udptunnel4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv4 UDP tunneling support
- KCONFIG:=CONFIG_NET_UDP_TUNNEL
+ KCONFIG:= \
+ CONFIG_NET_UDP_TUNNEL \
+ CONFIG_VXLAN=m
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ipv4/udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,udp_tunnel)
@@ -161,7 +163,9 @@ define KernelPackage/udptunnel6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv6 UDP tunneling support
DEPENDS:=@IPV6
- KCONFIG:=CONFIG_NET_UDP_TUNNEL
+ KCONFIG:= \
+ CONFIG_NET_UDP_TUNNEL \
+ CONFIG_VXLAN=m
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ipv6/ip6_udp_tunnel.ko
AUTOLOAD:=$(call AutoLoad,32,ip6_udp_tunnel)
@@ -444,7 +448,8 @@ define KernelPackage/iptunnel4
TITLE:=IPv4 tunneling
HIDDEN:=1
KCONFIG:= \
- CONFIG_INET_TUNNEL
+ CONFIG_INET_TUNNEL \
+ CONFIG_NET_IPIP=m
FILES:=$(LINUX_DIR)/net/ipv4/tunnel4.ko
AUTOLOAD:=$(call AutoLoad,31,tunnel4)
endef