summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/001-depends.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/001-depends.mk')
-rw-r--r--package/kernel/linux/modules/001-depends.mk7
1 files changed, 1 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/001-depends.mk b/package/kernel/linux/modules/001-depends.mk
index ed894311cc..d0ad083662 100644
--- a/package/kernel/linux/modules/001-depends.mk
+++ b/package/kernel/linux/modules/001-depends.mk
@@ -22,13 +22,8 @@ define AddDepends/nls
DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
endef
-
-define SetDepends/rfkill
- DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx) $(1)
-endef
-
define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
+ DEPENDS+= +USE_RFKILL:kmod-rfkill $(1)
endef