summaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/lantiq')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/Makefile1
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch11
2 files changed, 11 insertions, 1 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/Makefile b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
index 64a7cf3026..e0617aeb57 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
@@ -19,7 +19,6 @@ PKG_MD5SUM:=78bf61dbc3421123c6716b874a930759
PKG_FIXUP:=autoreconf
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_USE_MIPS16:=0
-PKG_CHECK_FORMAT_SECURITY:=0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch b/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch
index a3c7dfe26d..04fa36b15e 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch
+++ b/package/kernel/lantiq/ltq-vdsl-mei/patches/010-warnings.patch
@@ -24,3 +24,14 @@
if (pDynNfc->pRecvDataCntrl[pDynNfc->rdIdxRd].bufCtrl != MEI_RECV_BUF_CTRL_FREE) /* buffer in use */
{
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -201,7 +201,7 @@ else
+
+ drv_mei_cpe_common_cflags = \
+ $(AM_CFLAGS) -D__KERNEL__ -DLINUX -D__linux__ -DMODULE -DEXPORT_SYMTAB \
+- -pipe -Wno-format -Wimplicit -Wunused -Wuninitialized -Wsign-compare -Wstrict-aliasing
++ -pipe -Wall -Wimplicit -Wunused -Wuninitialized -Wstrict-aliasing
+
+ endif
+