summaryrefslogtreecommitdiffstats
path: root/package/kernel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/Makefile')
-rw-r--r--package/kernel/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index 37cb13e167..a030ad7236 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -32,5 +32,27 @@ endef
define Build/Compile
endef
+CONFIG_PACKAGE_kernel=y
+define Package/kernel
+ SECTION:=sys
+ CATEGORY:=Kernel
+ DEFAULT:=y
+ TITLE:=Virtual kernel package
+ DESCRIPTION:=Virtual kernel package
+ VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
+endef
+
+define Package/kernel/install
+ # nothing to do
+endef
+
+# this is more robust than ifdef around eval/call
+ifneq ($(DUMP),1)
+ define BuildKernel
+ $(call BuildPackage,kernel)
+ endef
+endif
+$(eval $(call BuildKernel))
+
include $(TOPDIR)/target/linux/*/modules.mk
include ./modules/*.mk