summaryrefslogtreecommitdiffstats
path: root/package/firewall
diff options
context:
space:
mode:
Diffstat (limited to 'package/firewall')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/20-firewall2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 40bbe300b0..2e236fe719 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/20-firewall b/package/firewall/files/20-firewall
index 38fbb94418..32f8a853da 100644
--- a/package/firewall/files/20-firewall
+++ b/package/firewall/files/20-firewall
@@ -29,7 +29,7 @@ config_foreach load_zones zone
[ ifdown = "$ACTION" ] && {
for z in $ZONE; do
local up
- config_get up $z up
+ config_get up "$INTERFACE" up
[ "$up" == "1" ] && delif "$INTERFACE" "$ifname" "$z"
done
}