summaryrefslogtreecommitdiffstats
path: root/package/diag/src/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/diag/src/Makefile')
-rw-r--r--package/diag/src/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/diag/src/Makefile b/package/diag/src/Makefile
new file mode 100644
index 0000000000..169f2e9725
--- /dev/null
+++ b/package/diag/src/Makefile
@@ -0,0 +1,19 @@
+# $Id$
+#
+# Makefile for diag driver
+#
+# Copyright (C) 2005 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+obj-m := diag.o
+
+ifeq ($(MAKING_MODULES),1)
+export-objs := diag.o
+
+-include $(TOPDIR)/Rules.make
+endif