summaryrefslogtreecommitdiffstats
path: root/package/devel/perf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/devel/perf/Makefile')
-rw-r--r--package/devel/perf/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/devel/perf/Makefile b/package/devel/perf/Makefile
index d6db053173..c999229324 100644
--- a/package/devel/perf/Makefile
+++ b/package/devel/perf/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/perf
SECTION:=devel
CATEGORY:=Development
- DEPENDS:= @USE_GLIBC +libelf1 +libdw +libpthread +librt +binutils
+ DEPENDS:= @!USE_UCLIBC +libelf1 +libdw +libpthread +librt +binutils
TITLE:=Linux performance monitoring tool
VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
URL:=http://www.kernel.org
@@ -57,6 +57,10 @@ MAKE_FLAGS = \
WERROR=0 \
prefix=/usr
+ifdef CONFIG_USE_MUSL
+ MAKE_FLAGS += EXTRA_CFLAGS="-include $(CURDIR)/musl-compat.h -D__UCLIBC__"
+endif
+
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \
-C $(PKG_BUILD_DIR) \