summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index d5212f09a8..94b807f5d5 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -138,8 +138,8 @@ endif
$(curdir)/index: FORCE
@echo Generating package index...
@for d in $(PACKAGE_SUBDIRS); do ( \
- [ -d $(PACKAGE_DIR)/$$d ] && \
- cd $(PACKAGE_DIR)/$$d || continue; \
+ mkdir -p $(PACKAGE_DIR)/$$d; \
+ cd $(PACKAGE_DIR)/$$d || continue; \
$(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
gzip -9c Packages > Packages.gz; \
); done