summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile b/package/Makefile
index a42b4b0dd0..a6b34be0f4 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -59,6 +59,7 @@ endif
# where to build (and put) .ipk packages
OPKG:= \
+ IPKG_NO_SCRIPT=1 \
IPKG_TMP=$(TMP_DIR)/ipkg \
IPKG_INSTROOT=$(TARGET_DIR) \
IPKG_CONF_DIR=$(STAGING_DIR)/etc \
@@ -108,9 +109,8 @@ $(curdir)/install: $(TMP_DIR)/.build
@mkdir -p $(TARGET_DIR)/etc/rc.d
@( \
cd $(TARGET_DIR); \
- for script in ./etc/init.d/*; do \
- grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
- IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) ./etc/rc.common $$script enable; \
+ for script in ./usr/lib/opkg/info/*.postinst; do \
+ IPKG_INSTROOT=$(TARGET_DIR) $$(which bash) $$script; \
done || true \
)
@-find $(TARGET_DIR) -name CVS | $(XARGS) rm -rf