summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index 786edd49f0..8e8c6c9a63 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -64,6 +64,14 @@ endif
$(curdir)/rootfs-prepare: $(TMP_DIR)/.build
@-$(MAKE) package/preconfig
@if [ -d $(TOPDIR)/files ]; then \
+ ( cd $(TOPDIR)/files; find -type f ) | \
+ ( cd $(TARGET_DIR); while :; do \
+ read FILE; \
+ [ -z "$$FILE" ] && break; \
+ [ -L "$$FILE" ] || continue; \
+ echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+ rm -f "$$FILE"; \
+ done; ); \
$(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
fi
@mkdir -p $(TARGET_DIR)/etc/rc.d